Solved

Exchange 2013/Shared Recipients

Posted on 2014-04-16
9
488 Views
Last Modified: 2014-05-12
OK, latest MS cock-up :-).

Why do I persist in pioneering for Microsoft.

I have installed a Windows 2012 R2 Domain and an Exchange 2013 Server, plus other 2012 R2 member servers.

I have created all user accounts and I'm now assigning Exchange accounts as I transition the companies old PC systems into the new domain.

There is an existing externally hosted IMAP shared mailbox for the customer services department which is an ideal candidate for a Shared Recipient mailbox in the Exchange environment.

Problem is no matter how I configure this Shared Mailbox I cannot get any accounts to be able to send emails from this shared mailbox.  I have assigned Full Access Permissions, Send As and Send on Behalf Of and all permutations of these and still no go.

What I expect to see is when I create a New Email is the From drop down box to show me the Shared Mailbox email address but it doesn't.  If I add it manually I immediately get a Non-Delivery Report.

In other configurations I have been able to Send but the email drops into the main recipients Sent Items rather than the expected Shared Recipients Sent Items.

All very time consuming and frustrating.

There is some reports on the web about similar issues but no fixes that I can see.

Has anyone got a definitive How-To guide?

Thanks

Brian
0
Comment
Question by:3D2K
  • 5
  • 4
9 Comments
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 40004114
First mistake:
" I have assigned Full Access Permissions, Send As and Send on Behalf Of"

DO NOT set all three. Either set Full Access with Send As or Full Access with Send on Behalf of.

Exchange caches permissions, therefore a permission change can take two hours to be fully effective.

When you add the address manually, the ONLY way that works is to select it from the GAL. If you attempt to add the address any other way it will usually fail.

If you want the drop down list, then add the shared mailbox as an additional ACCOUNT in Outlook. Run the new account wizard, you only have to enter the name and email address. Autodiscover will do the rest.

Oh, and if you installed Exchange 2013 on Windows 2012 R2 it MUST be Exchange 2013 SP1. Nothing else is supported.

Nothing is a cock up by Microsoft, or an error on their part, it works exactly as it should.

Simon.
0
 

Author Comment

by:3D2K
ID: 40004326
Simon

I have set the permission as Full Access, unable to Send emails from a shared mail box.

I have set the permission as Send As, unable to Send emails from a shared mail box.

I have waited 2 days for the cached permissions to propagate and still no go.

I used your recommendation to upgrade to Exchange 2013 SP1in a previous post.

I want the drop down list to show me the reply address of the shared mailbox, otherwise I don't see a way to Send As.

I'm not sure under what circumstances I was able to send emails, but I'll check that out again.  I suspect I had the Full Access and Send As permissions set, but then when I can send the email gets posted to the main mailbox Sent Items and not the Shared Mailbox.  Maybe that's the way it's supposed to work, but not any good for a customer service department that want to see the mail history sent/received for a shared mailbox.

Interestingly, from my research on this issue it appears that OWA works as expected.

Brian
0
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 40004424
If you are using Outlook 2010 and you add the shared mailbox as an additional ACCOUNT, then the email will go in to the shared mailbox Sent Items.
If you add the shared mailbox as an additional MAILBOX then it does not.

Outlook works on the basis that the sender owns the email, not the mailbox.

You must set Send As and Full Mailbox access and the account being granted the permission must not be a member of any of the protected groups (Administrators, Power Users, Domain Admins etc). You shouldn't need to wait two days - the cache flushes every couple of hours.

Simon.
0
 

Author Comment

by:3D2K
ID: 40004523
Simon

I need to start over again with all of this to properly log the steps I have taken to get to the position I am in.

I have just added the ACCOUNT as you explained by just adding the Name and Email address and the Account does appear as well as another set of Public Folders for the Shared Account :-).

When I create an email now then I can see the Shared Account email address in the drop down.  If I pick it and then hit Send the email parks itself in the Shared Mailbox Outbox and never gets sent :-(.

This is the procedure I have followed from scratch:

1) In Exchange Admin Center create a Recipients-Shared-"AppTeam" and added myself as Full Access/Send As.

I am am member of the Domain Admins, so are you saying that excludes me from being able to Send As?  I'll check it out with a regular user tomorrow.

2) When I start Outlook (2013) this Shared Recipient mailbox appears automatically.  I can turn off the auto mapping of the Account using Add-MailBoxPermission .... -AutoMapping $false if required.

3) The Mailbox appears in the list of mailboxes in Outlook now but I am unable to Send As as I can't see the email address I want to Send As in the drop down list.  I can't get the email address from the GAL as I don't see it.  I presume this is because a shared mailbox AD account is effectively disabled.  If I enter the email address manually then all I get is and NDR back in my main Inbox.

4) I have created a regular Exchange account and opened that in Outlook using File-Account-Settings-Change-More Settings-Advanced-Add.  I can Send As from this account but the Sent Emails appear in my Sent Items and not the Send As Sent Items.

So I have a bit of a halfway house where the required functionality works partly using either method but not fully for one or the other.

I'll sleep on it and have another go but I'm getting pretty close to blast-off where I will need the Shared Mailbox to behave as expected.

Brian
0
Highfive Gives IT Their Time Back

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 40004561
Being a member of Domain Admins means the permission will be removed automatically by Exchange. While you can undo that, it isn't recommended - you should really be using the split domain model - so having an admin level account and then a day to day account which is not an admin.

The method you used in step 4 is what I would expect, which is why I suggested the new account method.

Being a shared mailbox has no bearing on the visibility of the account in the GAL. There is an option to hide the account from the GAL on the properties of the mailbox.
However if you have just created the account and your Outlook is in cached mode then you may not see the account for up to 48 hours because the Offline Address Book is only generated once a day by default, and only downloaded by Outlook once a day (or a few minutes after being restarted).

Simon.
0
 

Author Comment

by:3D2K
ID: 40044784
Simon

Apologies for not responding to your last post.

I've been busy with other issues but have been thinking of you.

Looks like the Shared Mailbox feature in Exchange 2013 isn't what I expected it to be, ie a mailbox that I can give other users access to and allow them to Send As (and the sent emails to be saved in the Shared Mailbox Sent Items folder), easily

I have finally worked out how to do it and in my humble opinion it is not what I was expecting.

I have created a Shared Mailbox and assigned Full Access and Send As permissions for the users who are going to share this mailbox.

I then disabled the Outlook Auto-Mapping feature using a command similar to:

Add-MailboxPermission -Identity JeroenC -User 'Mark Steele' -AccessRight FullAccess -InheritanceType All -Automapping $false

If I auto mapped then I think I would not have been able to pick the mailbox to send as when I created a new email message.

I then added the mailbox in Outlook using:

AccountSettings-Email-Change-More settings-Add etc.

I then waited for a while to see if the send as email address would appear in the "From:" drop down (I'm still waiting), but I can manually choose the account from the GAL as you explained earlier.

At this point I can Send As for the account but any sent emails are saved in my Sent Items and not the Send As account Sent Items.  A similar issue is seen when deleting emails from the Send As account.  They drop into my Deleted Items.

Further investigation revealed that adding the following registry entries fixes both of these issues:

Logged on as the user:

HKEY_CURRENT_USER\Software\Microsoft\Office\15.0\Outlook\Preferences
         DWORD:DelegateSentItemsStyle, VALUE:1
HKEY_CURRENT_USER\Software\Microsoft\Office\15.0\Outlook\Options\General
         DWORD:DelegateWastebasketStyle,VALUE:4

Pretty straightforward really :-).

You seem to indicate in a previous post that it is a tad simpler than what I've explained here.

Maybe you'd like to comment on where I may be able to improve this as I have about 20 shared mailboxes and 70 users to set up :-(.

Brian
0
 
LVL 63

Accepted Solution

by:
Simon Butler (Sembee) earned 500 total points
ID: 40044800
This was your mistake:

AccountSettings-Email-Change-More settings-Add etc.

Don't do that.

In Account settings, add the shared mailbox as an additional ACCOUNT.
File, Add Account. Enter the email address.
As long as they have both full mailbox and send as permissions, then Outlook will connect. Items sent from the shared mailbox will be stored there.

No need to make any registry changes.

Simon.
0
 

Author Comment

by:3D2K
ID: 40044848
Simon

I'll have to create a new test account but will try again, maybe tomorrow and report back.

Brian
0
 

Author Closing Comment

by:3D2K
ID: 40058821
Simon

Well that was easy!

I can't believe how many dead ends I've been up trying to get this to work.

Now I just need to fix the one account I have set up manually and all is good.

For information:

I created a shared mailbox and assigned Send As permissions at that time.

Then edited the shared mailbox properties to add Full Access permissions for the same as Send As users.

I also took the step of using the Exchange Management Shell to disable Auto-Enable of the shared mailbox as detailed in a previous post, although that was a requirement of my installation.

Then started Outlook for each user and added an additional account as detailed in your solution.

Thanks

Brian
0

Featured Post

Enabling OSINT in Activity Based Intelligence

Activity based intelligence (ABI) requires access to all available sources of data. Recorded Future allows analysts to observe structured data on the open, deep, and dark web.

Join & Write a Comment

Easy CSR creation in Exchange 2007,2010 and 2013
Local Continuous Replication is a cost effective and quick way of backing up Exchange server data. The following article describes the steps required to configure Local Continuous Replication. Also, the article tells you how to restore from a backup…
This Experts Exchange video Micro Tutorial shows how to tell Microsoft Office that a word is NOT spelled correctly. Microsoft Office has a built-in, main dictionary that is shared by Office apps, including Excel, Outlook, PowerPoint, and Word. When …
This video shows how to remove a single email address from the Outlook 2010 Auto Suggestion memory. NOTE: For Outlook 2016 and 2013 perform the exact same steps. Open a new email: Click the New email button in Outlook. Start typing the address: …

705 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

21 Experts available now in Live!

Get 1:1 Help Now