yum timeout error while downloading the package

I am getting timeout error while downloading the package from yum repository, please help to resolve this issue.

Dependencies Resolved

 Package                                 Arch                                   Version                                                              Repository                                  Size
 tcpdump                                 x86_64                                 14:4.0.0-3.20090921gitdf3cb4.2.el6                                   local-base                                 336 k
Installing for dependencies:
 libpcap                                 x86_64                                 14:1.0.0-6.20091201git117cb5.el6                                     local-base                                 126 k

Transaction Summary
Install       2 Package(s)

Total download size: 461 k
Installed size: 1.1 M
Is this ok [y/N]: y
Downloading Packages:
http://centosrepo.abc.com/6/x86_64/libpcap-1.0.0-6.20091201git117cb5.el6.x86_64.rpm: [Errno 12] Timeout on http://centosrepo.abc.com/6/x86_64/libpcap-1.0.0-6.20091201git117cb5.el6.x86_64.rpm: (28, 'connect() timed out!')

There is no problem with the repository, I am able to browse the repo URL from browser.
Who is Participating?

Improve company productivity with a Business Account.Sign Up

rfportillaConnect With a Mentor Commented:
Is just Web ports.  80 and 443.
I'm sorry if these are silly questions, but I don't know exactly what you have tried and haven't tried.  

When you say that you tried the repo from the browser, is this a browser on the same computer that you are running yum from?  Have you tried doing a curl or wget to that link?  If curl and/or wget work, then yum should work.  This is where I would start.  

Do other rpms from this repo work?

If it gets too complicated and you need to get it done, download the rpm directly and install it from a local copy.
ceo_techConnect With a Mentor Commented:
Check your network connection,...
Build your data science skills into a career

Are you ready to take your data science career to the next step, or break into data science? With Springboard’s Data Science Career Track, you’ll master data science topics, have personalized career guidance, weekly calls with a data science expert, and a job guarantee.

MazdajaiConnect With a Mentor Commented:
Can you post your /etc/yum.repos.d/*.repo?

Try -
yum clean all
yum repolist

Open in new window

sudhirgoogleAuthor Commented:
still it didn't work, the server was placed in DMZ network, so want to know what are all the ports used by yum client to communicate with yum repository server, so that i can ask network team to verify those ports are opened on firewall.
gheistConnect With a Mentor Commented:
You can enter proxy settings in /etc/yum.conf if you were given ones.
MazdajaiConnect With a Mentor Commented:
Add those to your yum.conf and post the result.


Open in new window

I'm assuming you are using an internal repo.  Is this correct? When you said you need to request open ports, so you mean to the intensely network? This makes sense to me if that is what it is.

Are you using wget out curl the way I mentioned above?
add "enabled=0" string to /etc/yum.repos.d/<repo>.repo

I meant wget or curl.  (not "out")
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.