Solved

IIS 7 - HTTP Error 404.0 - Not Found

Posted on 2014-04-16
4
1,679 Views
Last Modified: 2014-04-21
I currently have a web page running on a XP Pro box using IIS 5.1. I am trying to convert over to a Win 7 box with IIS 7. I have copied the wwwroot folder along with the scripts, AdminScripts, iissamples, and mailroot folders and placed them under the inetpub folder ( probably not were they should go). When I open IE and type localhost it brings me to the main page but when I click on a link which should go to a different page I received an error "HTTP Error 404.0 - Not Found" I have attached a screen shot of the error. I am sure it is because it is looking in the wrong place for the file just don't know how to fix it?
Capture.PNG
0
Comment
Question by:nestey
  • 2
  • 2
4 Comments
 
LVL 35

Expert Comment

by:Bembi
ID: 40005162
I guess this is more a permission sissue, if the pathes are correct. They are shown in the error message.

Have  alook here:
http://stackoverflow.com/questions/11575386/foo-cmd-wont-output-lines-in-process-on-website
0
 

Author Comment

by:nestey
ID: 40006582
I'm not sure if the path is really correct as in the error the physical path shows c:\inetpub\Scripts\scripts\Patchgen.exe  but the actual path is where the files are in C:\inetpub\Scripts\Patchgen.exe.

I did check out your link but I think that might be a little over my head, I did not write the page just trying to move it from one machine to another.
0
 
LVL 35

Accepted Solution

by:
Bembi earned 250 total points
ID: 40013167
Your EXE is redirected to the C:\Inetpub\Scripts folder, and from there IIS follows our path "..\scripts\patgen.exe

So you may just crate the scripts subfolder or remove the "scripst" from your URL.

EXE files are a bit more restricted, this was the reason for the link, the first answer there i.e. points to web.config, where you can change the behaviour (allways mor save to use the GUI than to directly edit the web.config).

But if you can reach your target just by correcting the path, just do it.
0
 

Author Closing Comment

by:nestey
ID: 40013223
Thanks Bembi, I have gotten past that error message and now I can go to the index page. however there is a link on that page the runs another page that just doesn't do anything when I click on it, no error no nothing. I will need to work with the person how designed this site to see if he can tell what is going on. Thanks for the above help.
0

Featured Post

IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

Foreword (May 2015) This web page has appeared at Google.  It's definitely worth considering! https://www.google.com/about/careers/students/guide-to-technical-development.html How to Know You are Making a Difference at EE In August, 2013, one …
If you don't have the right permissions set for your WordPress location in IIS, you won't be able to perform automatic updates. Here's how to fix the problem.
Wufoo.com provides powerful tools for surveying targeted groups, and utilizing data from completed surveys to find trends, discover areas of demand or customer expectation, and make business decisions on products or services.
Learn how to set-up custom confirmation messages to users who complete your Wufoo form. Include inputs from fields in your form, webpage redirects, and more with Wufoo’s confirmation options.

708 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now