Solved

Windows 7 Pro - Remote Desktop Greyed out

Posted on 2014-04-17
8
10,023 Views
Last Modified: 2014-06-17
Hi there .

I've got a Windows 7 Professional PC on an SBS 2011 network. All the other PCs are fine but  this one has all the remote desktop options greyed out. It's on a domain but is the same even when logged in with a local admin account.

How can I turn it on?

I've checked Gpedit.msc (as with http://marktab.net/datamining/2011/07/18/technical-bulletin-windows-7-remote-desktop-options-grayed/) and all settings there are set to 'not configured' I Even tried setting
 "Allow users to connect remotely using Remote Desktop Services" to 'Enabled' but that didn't do anything either.

I've checked regedit.
HKLM\Software\Policies\Microsoft\Windows NT\Terminal Services.  fDenyTSConnections is set to 0

The PC is fully up to date with updates. SFC comes up clean, etc. Local Firewall has been reset to 'default'

In services:
Remote Desktop Configuration
Remote Desktop Services
Remote Desktop Services UserMode Port Redirector
are all set to manual and have started.

I've tried to access using a local admin account, the SBS administrator account and the standard domain users account for the machine (set as local admin). None of which work.

SBS 2011 has the PC mentioned in it's list of computers but is marked as 'offline'

I've tried deleting and reapplying the machine to the domain using https://connect but that didn't fix it either.

All other machine on the network are running OK and the user of the computer in qustion can access other PCs in the office remotely so it appears to be a PC related issue than a user related one.

Anything else I can try?
0
Comment
Question by:Dale303
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
  • 2
  • +1
8 Comments
 
LVL 14

Assisted Solution

by:Andy M
Andy M earned 167 total points
ID: 40006949
Usually this would be due to group policy settings - I would run a gpresults on the PC and check through that for any setting relating to it.

You could also try disabling the firewall and see if the SBS box lists it as online.
0
 
LVL 74

Assisted Solution

by:Jeffrey Kane - TechSoEasy
Jeffrey Kane - TechSoEasy earned 167 total points
ID: 40011080
You need to run a Group Policy report on that workstation to see what is causing the settings to be blocked.

Open an elevated CMD prompt and run the following:

gpresult /h gp.html

This will create a nice html report (called gp.html) in whatever directory you ran the command from.  If you need help interpreting it, post the full report back to this question.
0
 

Author Comment

by:Dale303
ID: 40011344
Already done that but the report is still on the machine. Will retrieve it after the Easter break
0
Don't Miss ATEN at InfoComm 2017!

Visit booth #2167 to see the  new ATEN VM3200 32 x 32 Modular Matrix Switch. Other highlights include the VE8950 4K HDMI Over IP Extender, VS1912 12-Port DP Video Wall Media Player  and VK2100 ATEN Control System. Register now with Free Pass Code ATEN288!

 
LVL 25

Assisted Solution

by:Tony Giangreco
Tony Giangreco earned 166 total points
ID: 40018462
Click Start, Run. Type GPEDIT.MSC and press Enter.

Navigate to:

Computer configuration,  Administrative Templates, Windows Components, Remote Desktop Services, Remote Desktop Session Host, Connections
 
then in the right-pane, double-click the "Allow users to connect remotely using Terminal Services" and set it to "Not configured"

Click OK, restart and test.
0
 
LVL 25

Expert Comment

by:Tony Giangreco
ID: 40018469
Before typing in that command, make sure you are logged in as the domain admin.
0
 

Accepted Solution

by:
Dale303 earned 0 total points
ID: 40045894
Hmm. Something's up with the DNS/DHCP on the server. The PC didn't have the same IP address as what the server thought it did for some reason. Set it up with a fixed IP and now it works fine.
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 40054723
Set it up with a fixed IP and now it works fine.

Not quite the best fix, since it will need to be managed manually from now on if things change on the network.  Better to clear up the DHCP problem.

At any rate, glad you have things working.
0
 

Author Closing Comment

by:Dale303
ID: 40138855
Issue resolved myself and was related to DNS, not RDP.
Thanks guys for helping eliminate the other possibilities.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The Windows functions GetTickCount and timeGetTime retrieve the number of milliseconds since the system was started. However, the value is stored in a DWORD, which means that it wraps around to zero every 49.7 days. This article shows how to solve t…
There are many software programs on offer that will claim to magically speed up your computer. The best advice I can give you is to avoid them like the plague, because they will often cause far more problems than they solve. Try some of these "do it…
Finding and deleting duplicate (picture) files can be a time consuming task. My wife and I, our three kids and their families all share one dilemma: Managing our pictures. Between desktops, laptops, phones, tablets, and cameras; over the last decade…
If you’ve ever visited a web page and noticed a cool font that you really liked the look of, but couldn’t figure out which font it was so that you could use it for your own work, then this video is for you! In this Micro Tutorial, you'll learn yo…

696 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question