Solved

Sql Server 2008 R2 Database and Table Permissions

Posted on 2014-04-17
8
406 Views
Last Modified: 2014-04-29
I'm using SqlServer Management Studio.
I want to grant a user datawriter permissions to all the tables in a database.  I created the user in the database and gave them the role datawriter.  But when I look a the permissions for a table, the user isn't listed.  Is there another step required?
Thanks,
Brooks
0
Comment
Question by:gbnorton
  • 5
  • 2
8 Comments
 
LVL 22

Expert Comment

by:plusone3055
ID: 40007092
yes in user mapping you have to check off the databases
0
 
LVL 22

Accepted Solution

by:
plusone3055 earned 500 total points
ID: 40007102
click logins --- that name  
rightclick that name ---- properties
then click user mapping
and click off the databses you want them to be a datawriter too :)
0
 

Author Comment

by:gbnorton
ID: 40007103
Under Database, Security, Users, myuser I have the role db_datawriter selected.  Where is the mapping at?
0
Best Practices: Disaster Recovery Testing

Besides backup, any IT division should have a disaster recovery plan. You will find a few tips below relating to the development of such a plan and to what issues one should pay special attention in the course of backup planning.

 
LVL 22

Expert Comment

by:plusone3055
ID: 40007110
you have to right click the user name and slect properties
in the properties window  there is a selection on the far left that says User Mapping
0
 
LVL 22

Expert Comment

by:plusone3055
ID: 40007120
I would send you a picture but that feature is currently disabled
I have provided the correct answer 1st...

heres complete steps

Create a user
right click him and select properties
under user mapping
check off a database and below check off data writer

keep repeating :)
0
 
LVL 22

Expert Comment

by:plusone3055
ID: 40007127
also you need to right click the database and hit REFRESH then you will see that user listed :)
0
 
LVL 69

Expert Comment

by:Scott Pletcher
ID: 40007300
>>  I created the user in the database and gave them the role datawriter. <<

From within that database, please double-check that you gave the user the db_datawriter role (bottom of screen) and not ownership of the db_datawriter schema (top of screen).


>> But when I look a the permissions for a table, the user isn't listed.  Is there another step required? <<

No.  Roles are not shown in the permissions list, only specific permission GRANTs, such as DELETE, INSERT, etc..
0
 

Author Closing Comment

by:gbnorton
ID: 40031066
Thanks for your help.  In the end I fixed it by adding the role datareader.
0

Featured Post

NEW Veeam Agent for Microsoft Windows

Backup and recover physical and cloud-based servers and workstations, as well as endpoint devices that belong to remote users. Avoid downtime and data loss quickly and easily for Windows-based physical or public cloud-based workloads!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
SSRS Subscription jobs disabled, yet still running 4 54
SQL Help 27 67
While in ##Table - Help 4 22
What can the "OPTION" in the GROUP help me in my query? 4 35
Hi all, It is important and often overlooked to understand “Database properties”. Often we see questions about "log files" or "where is the database" and one of the easiest ways to get general information about your database is to use “Database p…
This article explains how to reset the password of the sa account on a Microsoft SQL Server.  The steps in this article work in SQL 2005, 2008, 2008 R2, 2012, 2014 and 2016.
I've attached the XLSM Excel spreadsheet I used in the video and also text files containing the macros used below. https://filedb.experts-exchange.com/incoming/2017/03_w12/1151775/Permutations.txt https://filedb.experts-exchange.com/incoming/201…

685 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question