Solved

an extra site title in my blogs titles (fairly easy I hope)

Posted on 2014-04-17
6
281 Views
Last Modified: 2014-04-25
a few examples in bold the part I dont want or intended when typing each title (that part in bold its also my site's name):

Perder Peso sin Cirugia | Blog De Cirugia Plastica y MedicinaBlog De Cirugia Plastica y Medicina

blefaroplastia bogota | Blog De Cirugia Plastica y MedicinaBlog De Cirugia Plastica y Medicina

the first "blog de cirugia plastica y medicina" I typed it in that specific blog post, but the second ones are automatically added, and without a break between words as you can see. I want to only appear as titles the ones I type in every separate blog, without that automatic part in bold with my site title again, like this:

Perder Peso sin Cirugia | Blog De Cirugia Plastica y Medicina

blefaroplastia bogota | Blog De Cirugia Plastica y Medicina



heres my blog
http://susmedicos.com/blog/consejos-salud/riesgos-de-las-pastillas-para-bajar-de-peso/

thanks for any help
0
Comment
Question by:carpanta
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
6 Comments
 
LVL 1

Expert Comment

by:ceo_tech
ID: 40007940
Word press you need to adjust how it is displayed. in the admin panel.
0
 
LVL 70

Expert Comment

by:Jason C. Levine
ID: 40008004
ceo_tech, that's a terrible answer.  Where should the asker go in the admin panel?  What needs to be adjusted specifically?  Does the theme enter into it?  Are any plugins in play?

----------------------------------------------------------

carpanta,

There are multiple ways to tackle the problem.  The short version as to why this is happening is your current theme is set to automatically add the Page/Post title to the Site Title you set in Settings | General in the admin backend.  So by adding the "| Blog De Cirugia Plastica y Medicina" to end of the page title, the theme is only doing what it is programmed to do.

Two possible solutions:

1) Install and use a good SEO plugin such as the Yoast SEO:

https://wordpress.org/plugins/wordpress-seo/

This plugin allows to modify your overall site rules for page and post titles as well as on a specific page/post basis.  You need to go into the plugin settings and configure the Titles and Metas section but it will work.

2) Modify the theme's header.php file to remove the extra code causing the problem:

If you go to Appearance | Editor, you should see your theme's header.php file (unless this is a child theme...if so, let me know and I will provide alternate instructions).  Open that file in the editor and look for the title tag.  It should look something like this:

<title><?php wp_title(); ?><?php bloginfo('name'); ?></title>

Just remove the <?php bloginfo('name'); ?> and save the file.  That should stop the duplication.
0
 

Author Comment

by:carpanta
ID: 40008258
thanks Jason, I was left amazed by ceo_tech response because Im used to a certain standard in this place, both in the answers and posters, and suddenly I felt like in yahoo answers. Less helpful answer and mroe vague I cannot imagine, thank god you came to the rescue!

I already had the yoast plugin installed but I didnt have the "Force rewrite titles" enabled, I checked that option, do you think just by doing that the issue will be solved or do I need to go with your second solution?
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 70

Expert Comment

by:Jason C. Levine
ID: 40011965
I didnt have the "Force rewrite titles" enabled, I checked that option, do you think just by doing that the issue will be solved or do I need to go with your second solution?

Force Rewrite Titles should work.  If it doesn't, it's because the theme designer went a little nuts and the Yoast plugin can't actually find the title tag.
0
 

Author Comment

by:carpanta
ID: 40013307
jason, seems it worked, but could you please check? I dont trust my PC alone because I have so much stuff going on
0
 
LVL 70

Accepted Solution

by:
Jason C. Levine earned 500 total points
ID: 40013433
Looks good to me.
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In Part I (http://www.experts-exchange.com/Web_Development/Blogs/WordPress/A_8410-Getting-Started-In-WordPress-Part-I.html), I introduced you to the powerful WordPress backend, the WordPress administrative Dashboard.  In Part II, I will introduce yo…
First things first, I say this in many of my articles, but in this one you can take it as fact. I am not in any way an expert when it comes to WordPress. I am strictly a user. I don't know the programming languages involved, and although I could pro…
The purpose of this video is to demonstrate how to properly insert a Vimeo Video into a WordPress site or Blog. This will be demonstrated using a Windows 8 PC. Go to your WordPress login page. This will look like the following: mywebsite.com/wp…
The purpose of this video is to demonstrate how to prevent comment spam on a WordPress Website. This will be demonstrated using a Windows 8 PC. Plugin Akismet will be used. Go to your WordPress login page. This will look like the following: myw…

707 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question