[2 days left] What’s wrong with your cloud strategy? Learn why multicloud solutions matter with Nimble Storage.Register Now

x
?
Solved

Srv.sys should be running.  Srv.sys should be set to start on demand.

Posted on 2014-04-18
3
Medium Priority
?
4,744 Views
Last Modified: 2014-06-10
Hello,

My Windows Server 2012 file server stopped receiving faxes via the SMB connection, (although it used to work fine).  During my investigation I ran the Best Practices analyzer and was told that Srv.sys should be running.  Reasonable enough.  After further research I ran the command:

sc config srv start=demand

at an elevated command prompt and confirmed that this command was successful.

I tested the scan to SMB and it still did not work.  I ran "sc start srv" to force a start and the scanning worked.  After a reboot the scanning no longer worked however and the service was stopped again.

Using sc config srv start=auto seems to have the desire affect, in that the service is running and continues to do so after reboot.  But apparently this is not the "Best Practice" since the BPA now advises that it should be set to "demand".

Am wondering why "demand" is preferred to "auto" and why it is not working correctly.  No obvious clues in the logs but will dig further.

This is a VM running under ESX 5.1 and running VMware tools.

Expert insight on this issue is solicited.
0
Comment
Question by:fakaul
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
3 Comments
 
LVL 23

Expert Comment

by:Ayman Bakr
ID: 40011256
I believe srv.sys is important as a service for various functions and that the BPA advise to change it to demand is just a misleading information. I think this started with Windows 2012 R2 - isn't it?
0
 

Author Comment

by:fakaul
ID: 40011668
I believe so.  I have run in to serveral articles confirming that start=demand is the "desired" setting.  But it does not work on my server.  I must use start=auto for things to work.
0
 
LVL 23

Accepted Solution

by:
Ayman Bakr earned 450 total points
ID: 40012021
I think start=auto should be fine and do you no harm, however you can follow up with Microsoft to see if they have a fix to this discrepancy between BPA advise and the 'want' of your server/services!
0

Featured Post

Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Background Information Recently I have fixed file server permission issues for one of my client. The client has 1800 users and one Windows Server 2008 R2 domain joined file server with 12 TB of data, 250+ shared folders and the folder structure i…
OfficeMate Freezes on login or does not load after login credentials are input.
In this Micro Tutorial viewers will learn how to restore their server from Bare Metal Backup image created with Windows Server Backup feature. As an example Windows 2012R2 is used.
This tutorial will walk an individual through the process of installing the necessary services and then configuring a Windows Server 2012 system as an iSCSI target. To install the necessary roles, go to Server Manager, and select Add Roles and Featu…

656 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question