Solved

SharePoint 2010 Developer Dashboard Permissions

Posted on 2014-04-18
7
560 Views
Last Modified: 2014-04-24
I am trying to troubleshoot slow page loads and have been reading about the Developer Dashboard and how it could provide helpful information which I could pass along to our Web Team.

I have never used the Developer Dashboard before and have read article online on how to enable it but my question is that I do not want all users in my organize to see this information at the bottom of the page. I only want this information to be viewable to myself.

if this cannot be done, is there any other way for me to see what items are closing a page to load slowly or what web parts are being called
0
Comment
Question by:compdigit44
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
7 Comments
 
LVL 15

Accepted Solution

by:
colly92002 earned 500 total points
ID: 40010482
Use can use security trimming to manage who can use the developer dashboard.

See here for and example of setting permission via powershell:
http://www.sharepointboco.com/developer-dashboard-sharepoint-2010/


Here is a list of possible permissions levels (these map to the possible permission levels in the Sharepoint "Access Level" screen, part of the "permissions" options):
http://msdn.microsoft.com/en-us/library/microsoft.sharepoint.spbasepermissions.aspx

You probably want to use "ManageWeb".
0
 
LVL 20

Author Comment

by:compdigit44
ID: 40015213
I am sorry for the delay in getting back to you.

Ok, I opened SharePoint Designer and noticed our web team is using a master page that is from a third party  infowise and bamboo but after looking at the code "I believe" I see references to Developer Dashboard so I think I am on the right track.

My account is a farm admin and I did run the stsadm command to enable the Dashboard yet when I when to the main page nothing was displayed at the bottom of the screen,

I did read the links that you posted earlier but have to admit they when above my head.

I am trying this in our test environment first before doing it in production. The last thing I want to do is enable this and have all users see this information.

I wish there is a easy way via to GUI or powershell to say. User X and only X can see Dashboard info and no one else
0
 
LVL 15

Expert Comment

by:colly92002
ID: 40015629
If you have a custom masterpage it is possible  that the developer dashboard delegate control is NOT in the masterpage, in which case enabling it is not going to do anything.

Check your masterpage for the following markup:

<span class="s4-devdashboard">
			<Sharepoint:DeveloperDashboardLauncher
				ID="DeveloperDashboardLauncher"
				NavigateUrl="javascript:ToggleDeveloperDashboard()"
				runat="server"
				ImageUrl="/_layouts/images/fgimg.png"
				Text="<%$Resources:wss,multipages_launchdevdashalt_text%>"
				OffsetX=0
				OffsetY=222
				Height=16
				Width=16 />
		</span>

Open in new window



If this does not appear to be in your masterpage, then in your test environemtn you can use SPD to copy the curent masterpage to a new file, and add it to it in the appropriate place.  It normally appears at teh end of the ribbon markup, just before:

</SharePoint:SPRibbonPeripheralContent>
		</SharePoint:SPRibbon>

Open in new window





To switch it on, just use the script in this blog:
http://clarkupdike.blogspot.co.uk/2011/02/powershell-script-for-setting.html

To enable it for site admins only, change line 47 to:
$ddsetting.RequiredPermissions = 'ManageWeb'

Open in new window

0
Ransomware: The New Cyber Threat & How to Stop It

This infographic explains ransomware, type of malware that blocks access to your files or your systems and holds them hostage until a ransom is paid. It also examines the different types of ransomware and explains what you can do to thwart this sinister online threat.  

 
LVL 20

Author Comment

by:compdigit44
ID: 40015714
This is what I am seeing in part of my master page:

runat="server"
				Location="TabRowRight"
				ID="RibbonTabRowRight"
				CssClass="s4-trc-container s4-notdlg"><SharePoint:DelegateControl runat="server" ID="GlobalDelegate0" ControlId="GlobalSiteLink0" /><a href="#" tabindex="-1" style="display:none"></a><a href="#" tabindex="-1" style="display:none"></a><div class="s4-trc-container-menu"><div><wssuc:Welcome id="IdWelcome" runat="server" EnableViewState="false">
			</wssuc:Welcome><wssuc:MUISelector ID="IdMuiSelector" runat="server"/></div></div><SharePoint:DelegateControl ControlId="GlobalSiteLink2" ID="GlobalDelegate2" Scope="Farm" runat="server" /><span><span class="s4-devdashboard"><Sharepoint:DeveloperDashboardLauncher
				ID="DeveloperDashboardLauncher"
				NavigateUrl="javascript:ToggleDeveloperDashboard()"
				runat="server"
				ImageUrl="/_layouts/images/fgimg.png"
				Text="<%$Resources:wss,multipages_launchdevdashalt_text%>"
				OffsetX=0
				OffsetY=222
				Height=16
				Width=16 /></span></span></SharePoint:SPRibbonPeripheralContent></SharePoint:SPRibbon>

Open in new window

0
 
LVL 15

Expert Comment

by:colly92002
ID: 40015975
That looks fine.  Log on to your test server and open up a powershell (from the Sharepoint Management Shell option in the Sharepoint start menu) and run the commands above.  The best thing to do is create a new script file.

to do this:
1) create a new file n teh root of the C: drive called "EnableDD.ps1"
2) copy the code below into this file and save it.
3) start a Sahrepoint Management Shell
4) type:   cd C:\
5) type .\EnableDD.ps1
6) Choose "D" (for on demand).

You should now get an icon next to you name on the ribbon.  Only administrators will get this.  Run the script again to switch it off.


$svc=[Microsoft.SharePoint.Administration.SPWebService]::ContentService
 
$ddsetting=$svc.DeveloperDashboardSettings
 
$choiceOnDemand = New-Object System.Management.Automation.Host.ChoiceDescription `
        "On &Demand","Dashboard can be toggled via icon near Welcome Menu"
$choiceOn = New-Object System.Management.Automation.Host.ChoiceDescription `
        "&On","Dashboard is on for all pages"
$choiceOff = New-Object System.Management.Automation.Host.ChoiceDescription `
        "O&ff","Dashboard is off"
 
$choices = [System.Management.Automation.Host.ChoiceDescription[]]($choiceOnDemand, $choiceOn, $choiceOff)
$caption = "Specify Developer Dashboard Setting for Farm"
$message = "Current the dashboard is: $($ddsetting.DisplayLevel)"
$result = $Host.UI.PromptForChoice($caption,$message,$choices,0)
 
switch ($result) {
    0 { Write-Host 'Dashboard is now On Demand, toggle via icon near Welcome Menu'
        $ddsetting.DisplayLevel=[Microsoft.SharePoint.Administration.SPDeveloperDashboardLevel]::OnDemand
        break
      }
      
    1 { Write-Host 'Dashboard is now On' 
        $ddsetting.DisplayLevel=[Microsoft.SharePoint.Administration.SPDeveloperDashboardLevel]::On
        break
      }
    2 { Write-Host "Dashboard is now Off"
        $ddsetting.DisplayLevel=[Microsoft.SharePoint.Administration.SPDeveloperDashboardLevel]::Off
        break
      }
       
    default { throw "Developer Error"}
}
 
if ($result -ne 2) {
  $ddsetting.TraceEnabled = $true
  Write-Host @"
  Trace was also enabled.
  Note: v3 interface requires this on the master page for the Dashboard to render:
     <SharePoint:DeveloperDashboard runat="server" />
"@
} else {
    $ddsetting.TraceEnabled = $false;
    Write-Host "Trace was also disabled."
}
 
$ddsetting.RequiredPermissions = 'ManageWeb'
 
$ddsetting.Update()

Open in new window

0
 
LVL 20

Author Comment

by:compdigit44
ID: 40015980
When you mean adminmistrator do you mean farm admins? Any this be targets to just one users. I have other people who have admin rights in Sharepoint of which I do not want them to see this information
0
 
LVL 15

Expert Comment

by:colly92002
ID: 40016334
"ManageWeb" equates to a Site Collection Administrator.  It is the highest level of permission available in Sharepoint.  You cannot security trim to a user (or AD group) level - it has to be one of the permission levels here:
http://msdn.microsoft.com/en-us/library/microsoft.sharepoint.spbasepermissions.aspx
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Pimping Sharepoint 2007 without Server-Side Code Part 1 One of my biggest frustrations with Sharepoint 2007 in the corporate world is that while good-intentioned managers lock down the more interesting capabilities of Sharepoint programming in…
These days socially coordinated efforts have turned into a critical requirement for enterprises.
NetCrunch network monitor is a highly extensive platform for network monitoring and alert generation. In this video you'll see a live demo of NetCrunch with most notable features explained in a walk-through manner. You'll also get to know the philos…
In this brief tutorial Pawel from AdRem Software explains how you can quickly find out which services are running on your network, or what are the IP addresses of servers responsible for each service. Software used is freeware NetCrunch Tools (https…

734 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question