Server 2012 R2 upgrade fails on Dell server

Posted on 2014-04-18
Last Modified: 2016-11-23

Am trying to upgrade a Dell R310 server from 2008 R2 to 2012 R2 ( both Standard editions) but the upgrade fails towards the end of the process.  It does the usual prep work, copies files etc.  successfully.  It then boots into 2012 and you get the "Getting ready" and device enumeration % messages.  Finally, it tries to boot again into 2012 but crashes shortly after the Windows logo and rotating dots appear.

I assumed it was a BIOS or firmware problem, even although the server met Dell's minimum criteria for 2012.  Anyways, I updated the system BIOS, PERC H700 firmware and iDRAC as follows:

Bios:      1.12.0
H700 package:     12.10.6-000
H700 firmware:    2.100.03-2514
H700 BIOS:          3.18.0
iDRAC:    1.96.01

Despite the BIOS upgrades the system still fails.  You can't boot into safe mode and there are no error messages.  Have tried booting without driver signature checking and any other options I could find but with no luck.

Have reverted back to Server 2008 R2 for now, but we really need to upgrade this machine.

Any ideas on what I could try next?


Question by:MarkoIreland
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 4
LVL 14

Expert Comment

by:Justin Yeung
ID: 40008887
what features and services have been installed on the server?

Author Comment

ID: 40009071
It's a DC ( the only DC), DNS server, DHCP server, WSUS, WDS and Hyper-V.

I ran ADPREP before the upgrade.

LVL 14

Expert Comment

by:Justin Yeung
ID: 40009350
sounds like a small environment with no other hardware available?

isn't it? if you do, I will highly recommend to build a new dc and migrate the role over then follow a decommission and rebuild.

1. WSUS will not be upgraded.
The Known issue.
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.


Author Comment

ID: 40009474
Yes, it's a secondary school server with no other hardware available.  That's the reason for the in-place upgrade.  Trying to avoid doing a new install since it will mean a lot more work with limited resources.

Is there any way to determine what is actually failing?  I can enable logging from the advanced boot menu, but it's not much use if you can't boot into anything to read the log.

Safe mode doesn't work - presumably because 2012 isn't fully installed at this stage.
LVL 14

Accepted Solution

Justin Yeung earned 500 total points
ID: 40009499
what is the domain function level?

and did you prep the forest and domain?

adprep /forestprep

adprep /domainprep

and any anti virus software installed? if so remove it before upgrade.

i will suggest to remove WSUS before the process as well.

Author Comment

ID: 40009697
Yes, did both runs of ADPREP.

Symantec is installed, which I didn't think of removing.  Will also try and remove WSUS and see if it completes.


Author Closing Comment

ID: 40020556
Removed Symantec and upgrade sailed through.  Should have caught that myself but been a while since I did an in-place upgrade and must be rusty.

Thanks for pointer.
LVL 14

Expert Comment

by:Justin Yeung
ID: 40020559
good that you resolved it.

Featured Post

Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Background Information Recently I have fixed file server permission issues for one of my client. The client has 1800 users and one Windows Server 2008 R2 domain joined file server with 12 TB of data, 250+ shared folders and the folder structure i…
You might have come across a situation when you have Exchange 2013 server in two different sites (Production and DR). After adding the Database copy in ECP console it displays Database copy status unknown for the DR exchange server. Issue is strange…
In this Micro Tutorial viewers will learn how to use Boot Corrector from Paragon Rescue Kit Free to identify and fix the boot problems of Windows 7/8/2012R2 etc. As an example is used Windows 2012R2 which lost its active partition flag (often happen…
This tutorial will walk an individual through the process of installing of Data Protection Manager on a server running Windows Server 2012 R2, including the prerequisites. Microsoft .Net 3.5 is required. To install this feature, go to Server Manager…

733 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question