Solved

HTML Video won't Autoplay on site

Posted on 2014-04-19
6
32 Views
Last Modified: 2016-05-19
http://cctbeta.eastmeetsweb.com/services

I'm building a wordpress site using Layerslider as my slide builder. I’m trying to add some video to my slide using the HTML/Video/Audio option in the layers. I’ve uploaded the video (mp4) & it’s works but….it will not Autoplay even though I have set it to do so in the parameters. I have set the transition in at 2000ms. Do I not have the code correct or is it an issue with my host (Godaddy)?? Please help, thanks.

<video width=”640” height=”480” preload=”metadata” autoplay=”autoplay” controls> <source src=”/wp-content/uploads/2014/04/CCT-Flip.mp4” type=”video/mp4”> </video>
0
Comment
Question by:leftfooter007
  • 3
  • 2
6 Comments
 
LVL 70

Expert Comment

by:Jason C. Levine
ID: 40010594
Did you compose the code above in MS Word or take it from your site?  Because the quotes above are Word "fancy" quotes and that will screw up the parameters.
0
 

Author Comment

by:leftfooter007
ID: 40011063
Thanks Jason, the quotes are normal html quotes, I checked. Some more info....

I have been using Chrome as my browser which gives me the above situation. If I use IE the video sometimes autoplays, but starts in the middle of the video and the background is all messed up. If I use Firefox I can hear the sound of the video trying to load but it doesn’t load. Please help.
0
 
LVL 70

Expert Comment

by:Jason C. Levine
ID: 40011072
but starts in the middle of the video

That may indicate the moov atom is not at the beginning of the mp4 file.  

Run it through this tool:

http://renaun.com/blog/2010/06/qtindexswapper-2/

and then see if the results are better.
0
 

Author Comment

by:leftfooter007
ID: 40011089
Thanks again Jason. The application told me "Moov in proper place, processing not needed"
0
 
LVL 70

Accepted Solution

by:
Jason C. Levine earned 500 total points
ID: 40011464
Now that we know the video is okay, try changing the autoplay parameter to remove ="autoplay"

That param is like the controls one...it's either present or not in HTML5
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
error email attachment VB2010 5 46
character entities and entity references in XML 17 134
CSS Question.. 3 93
ColdFusion Rereplace 3 82
I found this questions asking how to do this in many different forums, so I will describe here how to implement a solution using PHP and AJAX. The logical flow for the problem should be: Write an event handler for the first drop down box to get …
Introduction Since I wrote the original article about Handling Date and Time in PHP and MySQL (http://www.experts-exchange.com/articles/201/Handling-Date-and-Time-in-PHP-and-MySQL.html) several years ago, it seemed like now was a good time to updat…
Explain concepts important to validation of email addresses with regular expressions. Applies to most languages/tools that uses regular expressions. Consider email address RFCs: Look at HTML5 form input element (with type=email) regex pattern: T…
The viewer will learn how to dynamically set the form action using jQuery.

820 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question