Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

HTML Video won't Autoplay on site

Posted on 2014-04-19
6
Medium Priority
?
63 Views
Last Modified: 2016-05-19
http://cctbeta.eastmeetsweb.com/services

I'm building a wordpress site using Layerslider as my slide builder. I’m trying to add some video to my slide using the HTML/Video/Audio option in the layers. I’ve uploaded the video (mp4) & it’s works but….it will not Autoplay even though I have set it to do so in the parameters. I have set the transition in at 2000ms. Do I not have the code correct or is it an issue with my host (Godaddy)?? Please help, thanks.

<video width=”640” height=”480” preload=”metadata” autoplay=”autoplay” controls> <source src=”/wp-content/uploads/2014/04/CCT-Flip.mp4” type=”video/mp4”> </video>
0
Comment
Question by:leftfooter007
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
6 Comments
 
LVL 70

Expert Comment

by:Jason C. Levine
ID: 40010594
Did you compose the code above in MS Word or take it from your site?  Because the quotes above are Word "fancy" quotes and that will screw up the parameters.
0
 

Author Comment

by:leftfooter007
ID: 40011063
Thanks Jason, the quotes are normal html quotes, I checked. Some more info....

I have been using Chrome as my browser which gives me the above situation. If I use IE the video sometimes autoplays, but starts in the middle of the video and the background is all messed up. If I use Firefox I can hear the sound of the video trying to load but it doesn’t load. Please help.
0
 
LVL 70

Expert Comment

by:Jason C. Levine
ID: 40011072
but starts in the middle of the video

That may indicate the moov atom is not at the beginning of the mp4 file.  

Run it through this tool:

http://renaun.com/blog/2010/06/qtindexswapper-2/

and then see if the results are better.
0
 

Author Comment

by:leftfooter007
ID: 40011089
Thanks again Jason. The application told me "Moov in proper place, processing not needed"
0
 
LVL 70

Accepted Solution

by:
Jason C. Levine earned 2000 total points
ID: 40011464
Now that we know the video is okay, try changing the autoplay parameter to remove ="autoplay"

That param is like the controls one...it's either present or not in HTML5
0

Featured Post

On Demand Webinar: Networking for the Cloud Era

Did you know SD-WANs can improve network connectivity? Check out this webinar to learn how an SD-WAN simplified, one-click tool can help you migrate and manage data in the cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

There are two main kinds of selectors in CSS: One is base selector like h1, h2, body, table or any existing HTML tags.  For instance, the following rule sets all paragraphs (<p> elements) to red: (CODE) CSS also allows us to define our own custom …
Introduction Since I wrote the original article about Handling Date and Time in PHP and MySQL several years ago, it seemed like now was a good time to update it for object-oriented PHP.  This article does that, replacing as much as possible the pr…
This tutorial will teach you the core code needed to finalize the addition of a watermark to your image. The viewer will use a small PHP class to learn and create a watermark.
The viewer will learn the benefit of using external CSS files and the relationship between class and ID selectors. Create your external css file by saving it as style.css then set up your style tags: (CODE) Reference the nav tag and set your prop…

721 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question