Solved

AHCI SSD - Toshiba Satellite M100

Posted on 2014-04-20
20
2,100 Views
Last Modified: 2014-04-27
I have this old laptop Toshiba Satellite M100 (PSMA0C-JG200E) bought in Canada.
I changed the HDD with SSD Samsung 840 EVO 250GB.
I am aware that SSD will not work at its full speed due to M100 mother board limitations, but still I would like to use it for a while until I wil buy a better laptop.

The laptop runs on Windows XP SP3, but I could install Win7.
The system supports only 32 bit, due to processor limitations.

After I installed the Win XP on SSD and the SSD software from Samsung (Samsung Magician) I noticed that AHCI mode is not enabled in order to improve a bit the SSD performance.

The BIOS does not provide any settings for AHCI.
I just update the BIOS with thw last version from toshiba.ca support, drivers, but still there is no AHCI.

The drivers from toshiba.ca does not indicate anything about AHCI controllers or at least I cannot see it for the moment.

In Device Manager I can see next info about IDE/ATA controller:

ATA Controllers

Using benchmark tools I measured in average around 120MB/s for read and write.
The M100 has SATA connector for HDD and I guess is SATA I, which sholud work up tp 150MB/s. The SSD can a lot more, but is OK for the moment only 150MB/s.

Question:
- What can be done to activate and test AHCI for Toshiba Satellite M100?
0
Comment
Question by:viki2000
  • 8
  • 4
  • 3
  • +3
20 Comments
 
LVL 11

Accepted Solution

by:
gmbaxter earned 250 total points
ID: 40011203
If it's not in the bios, it is either already running in ancient mode which looks unlikely or it is not supported.
0
 
LVL 11

Expert Comment

by:gmbaxter
ID: 40011204
Sorry that should say ahci not ancient
0
 
LVL 14

Assisted Solution

by:btdownloads7
btdownloads7 earned 200 total points
ID: 40011210
I don't think that it's worth the trouble for you to mess with it. First of all, without an option in BIOS, there is no way to enable AHCI at all. But even if you do find that option somehow, Win XP won't boot because it doesn't have AHCI drivers for the controller installed. And there is no easy way to install them in an existing installation -- the only way to do that would be if you had  different SATA controllers so that you could boot in legacy mode (as it is now), and also have the AHCI enabled on the other controller, which would let you install the AHCI drivers. But since that's not possible on a laptop, you would have to install XP fro scratch, and then install AHCI drivers for your controller using the textmode drivers by pressing F6 during the initial setup. And that's assuming that you can even get AHCI drivers for that controller, which you probably can't on an old laptop like that.
0
 
LVL 20

Author Comment

by:viki2000
ID: 40011211
How can  find out if it is not supported?
0
 
LVL 20

Author Comment

by:viki2000
ID: 40011213
I am ready to install WinXP from scratch and add the AHCI driver controller.
I found some lessons here:
https://aps2.toshiba-tro.de/kb0/HTD9401AN0000R01.htm
https://aps2.toshiba-tro.de/kb0/HTD9502M10000R01.htm

From where can I take the AHCI driver controler for 27C4?

I cannot find 27C4 reference in any AHCI drivers. Any other numbers as 27C6 or 27C5 seems available on net.

I can also install Win 7 32 bits if that would help in any way.
0
 
LVL 20

Author Comment

by:viki2000
ID: 40011222
I found new info, which confuses me:

1)  Looking into picdatabase.com for 27C4 I found indeed the Intel SATA controller:
http://www.pcidatabase.com/vendor_details.php?id=1302
 Inline with 0x27c4 we read:
Chip Number:       82801GBM/GHM
Chip Description:       SATA IDE Controller
Notes:       Updates

2) Then we go in Intel website, "Supported chipsets for AHCI":

http://www.intel.com/support/chipsets/imsm/sb/CS-012304.htm?wapkw=ich7m

and I see:
"Intel® 82801GBM I/O Controller Hub (ICH7M) - AHCI only"

If AHCI is the only mode, meaning by default, then why Samsung Magician cannot detect that and tells me to enable AHCI mode?

How can I tell if I a have AHCI enabled or not in my case?
0
 
LVL 14

Expert Comment

by:btdownloads7
ID: 40011234
Intel's drivers don't support AHCI for XP. There is a way to hack them, and I've done it on a couple of systems, but my guess is that since the Samsung software isn't detecting AHCI, then it's not enabled in BIOS. And in that case, there is nothing that you can do.  

Win 7 does support AHCI, so you could try installing it, and then see what the Samsung software says. If it still shows no AHCI, then there is nothing you're going to be able to do, unless you find a way to enable it in BIOS.
0
 
LVL 18

Expert Comment

by:web_tracker
ID: 40011625
I would just wait until you update your laptop. Unfortunately since even with the latest bios updates the system does not support ahci the laptop is just to old to gain the benefits of a faster ssd drive.
0
 
LVL 91

Expert Comment

by:nobus
ID: 40012090
maybe best to try to install Windows 7 - at least that has trim functions in built, while xp does not have that.
and maybe it cures the boot problem
0
 
LVL 20

Author Comment

by:viki2000
ID: 40012245
Here is my experience on short so far, which ends my searching:
1) Another guide how to enable AHCI: http://www.blah-blah.ch/it/how-to-s/enable-ahci/
2) According with these guys: http://www.bios-mods.com/forum/Thread-toshiba-satellite-pro-a100-phoenix-bios?page=3

my controller ICH7-M supports ACHI; it is a built in feature inside the SATA controller chip.
This is confirmed by the datasheet of the chip:
http://www.intel.com/content/dam/doc/datasheet/i-o-controller-hub-7-datasheet.pdf
I could not find my 27C4 chip and drivers, but I found discussions and drivers for similar as 27C0, 27C1.

http://www.mail-archive.com/linux-ide@vger.kernel.org/msg02213.html

I even tried the drivers for 27C5, 27C6, but then the PC boots and resets in a indefinite loop.
I am afraid this guy is right:
http://sumitmaitra.wordpress.com/2013/07/14/adding-ssd-to-my-desktop-ich7-ahci-and-bios-updates/

Of course I tried Win7 32bits, but that was lost time.


Here is how I understand it now:
- AHCI feature is a hardware part inside the SATA controller chip and can be activated only by BIOS. The operational system cannot do anything about it. The OS can only provide drivers to it, but cannot activate that hardware part.
- If there is no activation seen in BIOS, then just forget it, cannot be activated. The ICH7-M chip just happened to have that feature and is used in different motherboards, but at that time was the beginning of AHCI (http://www.geek.com/chips/intel-releases-ahci-specifications-including-serial-ata-553321/) or my motherboard just happened to have a SATA controller with AHCI feature, but was not intended to be used, that's why the BIOS has no possibility to change to AHCI.
- some guys try to run with a modified BIOS on similar laptops, but they did not have too much success www.bios-mods.com. I think is more than a simply BIOS activation. The BIOS software is only one part, should be additional circuits which allows to activate AHCI in SATA controller chip and to make use of the AHCI feature. They are missing for sure, that's why the BIOS option AHCI was not implemented and makes no sense to modify the BIOS with a customized version somewhere from internet to have that option.

If AHCI is not present in BIOS, then forget about the rest, you cannot have AHCI, even if the SATA controller has built in the hardware part. It just cannot be activated.
The OS plays no role here.


And here is how you can see if the current mode is IDE or AHCI: Device Manager - click right on IDE/SATA controller, properties, driver details:

IDE/AHCI
0
Free Trending Threat Insights Every Day

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

 
LVL 91

Expert Comment

by:nobus
ID: 40012302
>>  The OS can only provide drivers to it, but cannot activate that hardware part.  <<  i would not be so sure about that; you can even change bios settigns  online

>>  If there is no activation seen in BIOS, then just forget it, cannot be activated  <<  see above, some drivers will do it, others not; but if you don't have the option in bios - then YOU can't change it from there

maybe i missed it, but how do you see on your pic if it is ahci or not?
0
 
LVL 20

Author Comment

by:viki2000
ID: 40012426
The present controller set is IDE if we see "intelide" as in the picture above.
If it is something else which contains "iastor or ahci or  msahci" then we know the windows has installed the driver for AHCI.
In my case Windows has installed the driver for IDE/SATA.

I tried different Intel AHCI drivers, but they do not work, which is normal, because first the AHCI hardware part inside the SATA controller must be detected and is not because is not switched on and I cannot switch it on due to BIOS limitations and perhaps additional hardware circuits.

You can change the BIOS online and other tricks in updating the BIOS in various ways, but that will not add the AHCI setting to it. I have the last version of the BIOS. Other guys tried too, even to add such feature in a customized BIOS. It does not help. Sometimes they did not succeed to add the AHCI to BIOS.

I would like to see an example when the AHCI was not in the BIOS as a setting option and then with an update to see it. I started to doubt that there are such situations.

Even if you find, I do not think is my case.
Only by trying drivers in OS does not help.
It must be something which activate a hardware part in SATA controller and only after that the OS needs drivers.
0
 
LVL 91

Expert Comment

by:nobus
ID: 40012599
time to install W7 ..
0
 
LVL 20

Author Comment

by:viki2000
ID: 40012869
???
I did. You did not read everything what I wrote.
Has no relation with OS.
0
 
LVL 14

Expert Comment

by:btdownloads7
ID: 40012899
@viki2000: I'm sorry that you couldn't find the BIOS setting to enable AHCI, but that's exactly what I originally said -- you have to be able to do that, otherwise, it won't work.
0
 
LVL 91

Expert Comment

by:nobus
ID: 40013019
sorry, viki - i missed it
0
 
LVL 16

Assisted Solution

by:Mike T
Mike T earned 50 total points
ID: 40015962
Hi,

I would close the question and award most points to yourself I think as you have found the answer: it's not an option as the bios does not support it

It's a bit like cheap cars - sometimes they come with the same instrument panel as the deluxe models, but have some buttons and knobs blanked off. You can't enable it because the wires and hardware behind it are just not there.

Trying to install drivers for any feature you have not enabled at hardware level, is doomed to do extract and just shrug before evaporating.

Mike
0
 
LVL 20

Author Comment

by:viki2000
ID: 40016137
Mike,
Thanks for passing by and comment.
I am not that guy to assign points to myself. All the others deserve for their suggestions and the time for reading and writing. Sometimes I just need to speak with the smart guys from here. Is enough for me.

I do not close the question yet for a single reason: I do not know the circuits, the hardware connection between BIOS and SATA controller (the wires behind the instrument panel in the car). So, I decided to ask the profi guys from http://www.bios-mods.com to unlock my BIOS features and/or to add AHCI. If they want/can, then I just try and see if the SATA controller responds, then I know if there is any connection between BIOS and SATA controller chip. Or maybe is impossible for my BIOS and then I close the question here. I want to try that because I have read a similar problem with Toshiba Satellite another model, on http://www.bios-mods.com, which had no AHCI and they succeed to enable it. I have read too many things, I hope I got it right. I just wait for a while.
0
 
LVL 16

Expert Comment

by:Mike T
ID: 40016183
OK, well finger's crossed then. It all hinges on whether the wires are then just waiting for someone to add that button in the BIOS.
0
 
LVL 20

Author Closing Comment

by:viki2000
ID: 40025506
So far no chance with another modified BIOS.
I will stay with IDE mode, I have no other choice, except another laptop.
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

Learn more about the importance of email disclaimers with our top 10 email disclaimer DOs and DON’Ts.
Stuck in voice control mode on your Amazon Firestick?  Here is how to turn it off!!!
This video teaches viewers how to encrypt an external drive that requires a password to read and edit the drive. All tasks are done in Disk Utility. Plug in the external drive you wish to encrypt: Make sure all previous data on the drive has been …
The Bounty Board allows you to request an article or video on any technical topic, or fulfill a bounty request to earn points. Watch this video to learn how to use the Bounty Board to get the content you want, earn points, and browse submitted bount…

757 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

21 Experts available now in Live!

Get 1:1 Help Now