Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people, just like you, are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
Solved

ActiveSync is not working properly after migrating to new Exchange 2013 SP1 server?!

Posted on 2014-04-20
7
7,628 Views
Last Modified: 2016-06-09
Few weeks ago we have added new Exchange 2013 SP1 onto our existing Exchange 2007 environment. I have migrated my mailbox to the new Ex2013 server. Everything (send/receive - internally/externally, OWA, OutlookAnywhere) for me and the existing Ex2007 users works fine. The only thing I have trouble with is the ActiveSync! After migrating to the new Ex2013 server my phone stops getting new emails…, existing Ex2007 users don’t have any problems with their mobile phones.

Before I was going to test ActiveSync with Microsoft Remote Connectivity Analyzer remotely I was trying to do internal test with ActiveSync Tester (free diagnostic tool from https://store.accessmylan.com/main/diagnostic-tools)

I did ActiveSync test for my user account with ActiveSync Tester and here is what I have: (please refer to pictures attached)

As you can see from the error  ActiveSync Tester detects ActiveSync on Ex2013 server however something wrong there with form-based auth?! I can’t see any differences in settings for ActiveSync virtual folders in Ex2007 and Ex2013 virtual folders?!

What I’m missing here?! Please help.
444326.jpg
444330.jpg
0
Comment
Question by:Olevo
7 Comments
 
LVL 9

Assisted Solution

by:Mahesh Sharma
Mahesh Sharma earned 200 total points
ID: 40012111
0
 
LVL 11

Expert Comment

by:hecgomrec
ID: 40012470
I had a similar issue with some phones on one of my environments not too long ago.

I never went into the issue of permissions like in my 2010 environments.

I discovered that Android phones will connect immediately after re-creating the account on the device and accepting the new security settings. But for BB and iOS I had to go the extra mile.  You have to go in the Exchange Admin Center, mobile, mobile devices, Device Access Rules and add the device family you want to allow in your environment.

In my case I added the whole family for BB and iPhone only.

Also, keep in mind that some devices may be configured to use IMAP and this service does not start Automatically on Exchange 2013 so you will have to change its settings if you wish to use this service.

Hope that helps!
0
 
LVL 31

Accepted Solution

by:
Gareth Gudger earned 300 total points
ID: 40013766
Go into your user account in AD Users and Computers. (Make sure you have Advanced checked from the View menu.)  Then go to the Security tab, Advanced and select Allow Inheritable permissions. Retry your ActiveSync.
0
PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

 
LVL 1

Author Comment

by:Olevo
ID: 40027087
Wow…, looking at the error messages I would never ever guessed about permission inheritance. Testing ActiveSync internally is looking good. Now, I need to setup some firewall rules so I can test ActiveSync externally.
0
 
LVL 31

Expert Comment

by:Gareth Gudger
ID: 40027253
Awesome!
0
 
LVL 31

Expert Comment

by:Gareth Gudger
ID: 40027264
You can also test external ActiveSync issues with this tool from Microsoft.

https://testconnectivity.microsoft.com/
0
 

Expert Comment

by:robertgibson
ID: 41645924
Gareth,  I'm getting the same error moving from Exchange 2010 to Exchange 2016.  I've enabled Inheritable permissions for the user but I'm still getting the same error on the 2010 server.

1052: The Exchange ActiveSync user domain\username has a mailbox on a Client Access server running a newer version of Exchange. Exchange ActiveSync doesn't support proxying users to Client Access servers running a newer version of Exchange. The user needs to connect to a newer Client Access server.

On the 2016 server it shows the users phone and it says access granted.
Any suggestions?
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This process describes the steps required to Import and Export data from and to .pst files using Exchange 2010. We can use these steps to export data from a user to a .pst file, import data back to the same or a different user, or even import data t…
In-place Upgrading Dirsync to Azure AD Connect
In this video we show how to create an Accepted Domain in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Ac…
A short tutorial showing how to set up an email signature in Outlook on the Web (previously known as OWA). For free email signatures designs, visit https://www.mail-signatures.com/articles/signature-templates/?sts=6651 If you want to manage em…

839 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question