How do I setup Ghostscript to open an .eps file in Gimp?

I am trying to open an .eps file using Gimp. I found links to a plugin called Ghostscript that should allow me to open this file.  I downloaded the 64-bit version from:, and can't figure out where to go from here.

I know at some point I'm supposed to add a system variable that points to the location of Ghostscript, but first I need to let Gimp know I have it, right?

 Any pointers?
Sina MaySenior Product Master of DisasterAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Paul SauvéRetiredCommented:
You mention the version of GIMP as 2.0, this is an older version... Are you also using it under Windows XP?

If so, you have to create an Environment Variable: Variable Name is GS_PROG and Variable Value is the path to GS (ex. "C:\Program Files\gs\gs8.54\bin\gswin32.exe".

Please see the details here: Problem opening .eps files
Sina MaySenior Product Master of DisasterAuthor Commented:

I double checked this morning and my Gimp is version 2.8.1 and I'm using Windows 7. I've added the environment variable and on trying to open the file Gimp tells me:

"Opening 'C:\Users\____\Downloads\sample_6.eps' failed:

Could not interpret Postscript file 'C:\Users\____\Downloads\sample_6.eps'"
CompTIA Security+

Learn the essential functions of CompTIA Security+, which establishes the core knowledge required of any cybersecurity role and leads professionals into intermediate-level cybersecurity jobs.

Paul SauvéRetiredCommented:
I also have Gimp2.8.1 in Windows 7.

Here are my settings. The bottom part shows the location of Ghostscript on MY PC. Please note that I point to gswin64c.exe and not to gswin64.exe.

I have never had to let Gimp know. Don't forget to restart GIMP if it is open when you add/modify the values.Environment Variable GS
Sina MaySenior Product Master of DisasterAuthor Commented:
Thanks for the screenshots. It helped me notice that I created a user variable instead of a system variable (Doh!), but even after fixing this and trying both executables for Ghostscript I get the same error.

 sys variables and gimp
Paul SauvéRetiredCommented:
I guess you didn't notice my note above:
Please note that I point to gswin64c.exe and not to gswin64.exe (as YOU have done).
Sina MaySenior Product Master of DisasterAuthor Commented:
I did notice, and ended up trying both executables. :)

"but even after fixing this and trying both executables for Ghostscript I get the same error. "

Neither one allowed me to open the file.
Paul SauvéRetiredCommented:
I know that GIMP has problems with certain .eps files, it seems to depend on which program was used to create them.

Here is a link to a file that my version of GIMP can open: Please test to see if you can open it.

I had to use the site, since Experts Exchange doesn't allow .eps formats directly!
Sina MaySenior Product Master of DisasterAuthor Commented:
Hmmm... No luck. Still getting the same error.
Paul SauvéRetiredCommented:
Pleas let me check this further, I'll get back to you.
Paul SauvéRetiredCommented:
The only other thing  I can think to do is to remove GIMP and reinstall it... I have reinstalled several versions of GIMP since I first created the Environment Variable for Ghostscript and have been able to open .eps files with no problems.

I can't seem to find anything else on this subject, except that some users still seem to have issues with this.
Sina MaySenior Product Master of DisasterAuthor Commented:
I gave uninstalling a shot but no luck. I'm going to keep this thread open for awhile longer in case you or someone else has another idea, or I run into an answer myself. Thanks for your efforts so far!
I am also running into this issue, with GIMP 2.8.14.  Has anyone been able to resolve this?  I'm at a loss as to what else to try and I'd really like to be able to recommend GIMP as an alternative to the Adobe suite...
Sina MaySenior Product Master of DisasterAuthor Commented:
Hi Gilead,

I never did get this to work. Did you try the suggestions Paul gave me? I'd love to be able to close this out.
Paul SauvéRetiredCommented:
I'm afraid I'm out of ideas???

Gilead, can you please tell me what version of GIMP you are using? And Windows???
Also, it shouldn't make any difference 32b or 64b

Here is a link to Install Ghostscript for Windows and GIMP
GhostScript for Windows supports PostScript (.ps) and Encapsulated PostScript (.eps) files. You can download it and install it here. To install GhostScript for Windows and GIMP, you’ll want to download a Windows distribution with an installer (.exe), and follow the installation instructions.

I hunted a bit further and found this posting that details a small bug in the GhostScript library files that are included with GIMP 2.8.*.  I followed the instructions to copy the GhostScript .dll into the GIMP install folder, and everything began to work.  Based on the explanation, the solution outlined should help anyone with GIMP 2.8.* and GhostScript errors, though I am using windows 8.1 64-bit.

Same link:

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Paul SauvéRetiredCommented:
This seems to be the correct solution...

I have ONE version of the GIMP 2.8.14 that did not function correctly, and now it does! Full points to you!
Sina MaySenior Product Master of DisasterAuthor Commented:
I'll try this when I get back to my desktop! Thanks guys!
Brian MatisProduct ManagerCommented:
Hey Sina, just wondering if you ever got a chance to try out the latest proposed solution?
Sina MaySenior Product Master of DisasterAuthor Commented:
Sorry for letting this sit around so long, guys! I don't have the machine this was set up on any longer, but points to Gilead for the solution that helped Paul, and points to Paul for his initial solution as I think this would solve most instances of this bug. Thanks!
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Illustration Software

From novice to tech pro — start learning today.