• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3508
  • Last Modified:

vmware vsphere esxi 5.5 - 5.5 update 1 esxcli

Hi All,

I have made an SSH connection to my esxi 5.5 host.  I have uploaded update-from-esxi5.5-5.5_update01.zip to datastore2.  After running the command -

esxcli software vib install -d /vmfs/volumes/datastore2/update-from-esxi5.5-5.5_update01.zip

After running, it states -
Installation Result
Message: Host is not changed
Reboot Required: false
VIBs Installed:
VIBs Removed:
VIBs Skipped: [lists many VIBs]

What's happening here ?  I can't confirm this, but is it due to the fact that it is an evaluation license ?

Thanks
esxcli-VIB.JPG
0
moo_c_o_w
Asked:
moo_c_o_w
  • 4
  • 3
1 Solution
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
did you follow the procedure exactly as my EE Article

HOW TO: Upgrade from VMware vSphere Hypervisor ESXi 5.1 to VMware vSphere Hypervisor ESXi 5.5 for FREE

It's the same process for an upgrade!

Did you put the ESXi Host into maintenance mode?

you could also try

esxcli software vib update
0
 
moo_c_o_wAuthor Commented:
I saw your articles Hancock.  I followed something similar, but obviously will have to try the real deal.

Just to confirm -

trial license no issue ?

will maintenance mode make it 'fail' the way it did ?

Will try and let you know.  Thanks again.
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
The Server must be in maintenance mode, and VMs must be OFF!

Trail License should not be an issue, but you must pick the correct update, to update!
0
Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
moo_c_o_wAuthor Commented:
Hancock... I'm awarding points because I had overlooked maintenance mode [a requirement for VUM... so it was silly to overlook esxcli].  However, I believe the reason why all VIB's skipped was because the host was already patched.  Build 1623387 is 5.5 U1.

Just wanted to update everyone to carefully check current build.

Thanks for you prompt reply.
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Make sure you use the correct patch for Heartbleed!

and do not use 5.5 U1 with NFS!
0
 
moo_c_o_wAuthor Commented:
Fun times for VMware.  No doubt.
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
and all the other vendors also with products affected!
0

Featured Post

[Webinar] Kill tickets & tabs using PowerShell

Are you tired of cycling through the same browser tabs everyday to close the same repetitive tickets? In this webinar JumpCloud will show how you can leverage RESTful APIs to build your own PowerShell modules to kill tickets & tabs using the PowerShell command Invoke-RestMethod.

  • 4
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now