• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 343
  • Last Modified:

Offline cache mode prevents Outlook from finding search results

Strange issue here, cant seem to find anyone else having the issue.

When i enable Offline Cache mode on Outlook 2007 connected to Exchange 2010, in Outlook I cannot do a search and get results, it comes back 0 results found.

However if i disable Offline Cache mode, i am able to search the mailbox.

Furthermore, in windows 7, the indexing service shows there are about 100,000 indexed and in Outlook it shows 0 items left to index.

Any ideas?
0
Brad Nelson
Asked:
Brad Nelson
  • 4
  • 3
1 Solution
 
SreRajCommented:
Hi,

Please try rebuilding index for Microsoft Outlook.

Open Control Panel -> Indexing Options
Select 'Microsoft Outlook' and click on Advanced button
In 'Index Settings' -> Troubleshooting click on Rebuild button

This will delete existing index for outlook and create a new one. Indexing will not work if the computer is busy with other operations. Please keep the computer turned on for sometime so that indexing gets complete.

Please refer following article for more information.

https://kis.kellogg.northwestern.edu/Pages/OutlookIndexingIssues.aspx
0
 
Brad NelsonOwnerAuthor Commented:
SreRaj,
I not only rebuilt the index, after that didn't work i deleted the db and restarted the index service to create a fresh database, it completed and even outlook shows it indexed, but search still does not work.

Thanks for the suggestion.
0
 
SreRajCommented:
Please check for any critical error logged in Application Log in Event Viewer.

Also, have you tried creating a new Outlook Profile and see if Indexing is working.
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
Brad NelsonOwnerAuthor Commented:
yes created new profile, same as original with cachemode off it works, cachemode on it doesn't.

there are no errors in the app logs regarding the indexer
0
 
SreRajCommented:
Please try enabling logging in Outlook for Search Operations.

To enable logging, the following registry key need to be set.

Path: HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Outlook\Search
DWORD: EnableLogging
Value: ffff0000

The log files will be generated in the path, %TEMP%\outlook logging\

After the registry key is set, please close and re-open Outlook and then search for items. Then, check the contents of Outlook.ost.log for any events regarding indexing errors.

http://support.microsoft.com/kb/2769651
0
 
Brad NelsonOwnerAuthor Commented:
It appears a windows update fixed the issue, You can close this ticket.
0
 
Brad NelsonOwnerAuthor Commented:
Windows update corrected the issue.
0

Featured Post

Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

  • 4
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now