Fedora 10, mySQL 5.0.67 has a different login steps from FC-7, mySQL 5.0.37, and I got an error of access.

Up to MySQL 5.0.37 (FC-7), there were username and password for login to get into the MySQL server.    However, when I am in Fedora 10, MySQL 5.0.67, I got different login steps,

$ mysql -u username -p
password :   xxxxxx           MySQL 5.0.37 (FC-7)


$ mysql -u username -p
ERROR:   Access denied for user ' '@'localhost' to database '   '.
                                                  Fedora 10, MySQL 5.0.67


I did exactly the same way of initial setting to both MySQL server (Fedora Core 7 and Fedora 10), which I learned from textbook "Learning SQL".   That procedure was as below,


$ mysql -u root
(Welcome messages)

mysql>  UPDATE  mysql.user
          ->   SET  password =  PASSWORD('root_password')
          ->   WHERE User =  'root';
(Query OK, message)

mysql>  FLUSH PRIVILEGES;
(Query OK)

mysql>  grant all privileges on *.* to 'mkido'@'localhost'  identified by 'xxxxx(mkido_password)';

(Query OK message)


=====================================================
After this initial root and username(mkido) setting, when I issue the following command line, I got an error like below, PLEASE help me, how to deal with !

[username@.. ~]$  mysql   -u  mkido
ERROR 1045 ..:    Access denied for user 'mkido'@'localhost' (using password: NO)

OR - OR - OR -

[username@.. ~]$  mysql   -u  mkido -p
ENTER password :   XXXXX     (I typed in my password.)
ERROR 1045 ..:    Access denied for user 'mkido'@'localhost' (using password: YES)

What do you think ?    Thanks.
mkidoAsked:
Who is Participating?
 
Dave BaldwinConnect With a Mentor Fixer of ProblemsCommented:
I think something else is going on because that login to 'mysql' hasn't changed since at least version 3.23 and remains the same in the current version.   http://dev.mysql.com/doc/refman/5.7/en/mysql.html  You can try the 'long' syntax:
mysql --user=user_name --password=your_password db_name

Open in new window

0
 
mkidoAuthor Commented:
I agree.    Something else is going on.    It is absolutely weird.    

(shell) $ mysql -u root_password      OR
(shell) $ mysql  -u user_paassword

makes me get into MYSQL, and I see welcome message.     They must be root or username.    Apparently, user and password appear mixed up (or exchanged).     Very weird.    


 Well, let me continue later, because I may want to completely reload the Fedora 10 entire system.    There is no data or special setting on this computer (local, not on net).   So, I have no problem of complete cleaning up.
0
 
Dave BaldwinFixer of ProblemsCommented:
Ok.
0
Cloud Class® Course: Certified Penetration Testing

This CPTE Certified Penetration Testing Engineer course covers everything you need to know about becoming a Certified Penetration Testing Engineer. Career Path: Professional roles include Ethical Hackers, Security Consultants, System Administrators, and Chief Security Officers.

 
mkidoAuthor Commented:
THIS TIME, NORMAL LOGIN IS WORKING :


I have completely reloaded the entire Fedora 10 Operating System.   Because the computer is a local one, and this procedure only took about one hour or so.    

After I started the band new Fedora 10 computer, I started mysqld as below,
   
# /etc/init.d/mysqld    start

then initialization of MySQL database and starting MySQL were [OK].   Then, I did

$ mysql -u root

mysql>  UPDATE  mysql.user
          ->   SET  password =  PASSWORD('root_password')
          ->   WHERE User =  'root';

mysql>  FLUSH PRIVILEGES;

mysql>  grant all privileges on *.* to 'mkido'@'localhost'  identified by 'xxxxx(mkido_password)';


AFTER THIS SETTING, EVERYTHING works normal.   ALL LOGINs work normal.  
Perhaps, somewhere in the MySQL setting, I messed up at the previous time.     During the previous setting I had to break up one time procedure into two times or more, due to displaying to my student, who is learning MySQL as a newbie.       Thank you so much, Dave.    Practically I fixed it by Operating System (Fedora 10) reloading.
0
 
Dave BaldwinFixer of ProblemsCommented:
I'm glad you got it working .
0
 
Dave BaldwinFixer of ProblemsCommented:
Thanks for the points.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.