Solved

When to use SFP Module.

Posted on 2014-04-23
16
795 Views
Last Modified: 2014-04-24
Dear Experts,
I want to purchase two core switch and three access switch. All with redundancy.Attaching the diagram which will make you understand properly. My question is when to use SFT as an uplink between the core and access switch. I need the connectivity between core and access switch to be 1 GB. Can I uplink  all of them in the normal ethernet port or do I need to uplink them with SFP. All the core and access switch will be in the same rack.
Regards.
Core---Access-switch-requirement.JPG
0
Comment
Question by:ibu1
  • 7
  • 5
  • 4
16 Comments
 
LVL 10

Expert Comment

by:Rafael
Comment Utility
You can do either.  However, I would suggest trunking them for redundancy from the Ethernet ports and save the SFP for Long haul connections to other devices as your network evolves.
0
 
LVL 21

Expert Comment

by:Rick_O_Shay
Comment Utility
If you don't need the longer distance you can get with fiber nor the 10 GB speeds between switches then you can use regular copper ports and not need the SFPs.
0
 
LVL 12

Author Comment

by:ibu1
Comment Utility
So you mean that 1 GB uplink from core to access switch does not required SFP, if we keep apart the network evolution in mind.
0
 
LVL 21

Expert Comment

by:Rick_O_Shay
Comment Utility
SFP's only need to be used if you are not using 1gb which copper ports can handle.
0
 
LVL 12

Author Comment

by:ibu1
Comment Utility
Please comment on above properly.
Thanks
0
 
LVL 21

Expert Comment

by:Rick_O_Shay
Comment Utility
Correct. 1GB uplinks can be done with normal copper ports and requires no SFP.
0
 
LVL 10

Accepted Solution

by:
Rafael earned 500 total points
Comment Utility
Yes, you can do this without the SFP's and just use Copper. I would suggest using CAT 5e as it is cost effective over CAT 6 and much better than typical CAT 5.

However, I wanted to ask if there is a requirement for 10G from your core switches to your HP Flex? If so what type of core switches are you using? 4506's with 3750's as your access switches ? How far away are the HP Flex's ?

Just so you know, they do make 10G SFP to SFP cables that are either active or passive and range from 1m to 10m+.  I use them from time to time.  Purchasing four cables of 10m in length is more cost effective than 1-2 10GB SFP GBICS. Here is a link to a company that shows more details in pricing. You can find others by searching the web.

In either case, since you're building this new, as I mentioned previously, make sure you trunk your core switches for redundancy. Also split your links as you have illustrated to your access switches.  I've put together the following sequence of commands based on your design.


coreswitchA#Config t
coreswitchA#interface GigabitEthernet1/1
coreswitchA#description * Trunk to Core Switch B (Gi 1/1) *
coreswitchA#switchport trunk encapsulation dot1q
coreswitchA#switchport trunk allowed vlan (List your VLANS)
coreswitchA#switchport mode trunk
coreswitchA#channel-protocol lacp
coreswitchA#channel-group 1 mode passive
coreswitchA#interface GigabitEthernet1/2
coreswitchA#description * Trunk to Core Switch B (Gi 1/2) *
coreswitchA#switchport trunk encapsulation dot1q
coreswitchA#switchport trunk allowed vlan (List your VLANS)
coreswitchA#end

coreswitchB#Config t
coreswitchB#interface GigabitEthernet1/1
coreswitchB#description * Trunk to Core Switch A (Gi 1/1) *
coreswitchB#switchport trunk encapsulation dot1q
coreswitchB#switchport trunk allowed vlan (List your VLANS)
coreswitchB#switchport mode trunk
coreswitchB#channel-protocol lacp
coreswitchB#channel-group 1 mode passive
coreswitchB#interface GigabitEthernet1/2
coreswitchB#description * Trunk to Core Switch A (Gi 1/2) *
coreswitchB#switchport trunk encapsulation dot1q
coreswitchB#switchport trunk allowed vlan (List your VLANS)
coreswitchB#end



accessswitchA#Config t
accessswitchA#interface GigabitEthernet1/1
accessswitchA#description * Trunk to Core Switch A (Gi 1/3) *
accessswitchA#switchport trunk encapsulation dot1q
accessswitchA#switchport trunk allowed vlan (List your VLANS)
accessswitchA#switchport mode trunk
accessswitchA#channel-protocol lacp
accessswitchA#channel-group 2 mode passive
accessswitchA#interface GigabitEthernet1/2
accessswitchA#description * Trunk to Core Switch B (Gi 1/3) *
accessswitchA#switchport trunk encapsulation dot1q
accessswitchA#switchport trunk allowed vlan (List your VLANS)
accessswitchA#end


accessswitchB#Config t
accessswitchB#interface GigabitEthernet1/1
accessswitchB#description * Trunk to Core Switch A (Gi 1/4) *
accessswitchB#switchport trunk encapsulation dot1q
accessswitchB#switchport trunk allowed vlan (List your VLANS)
accessswitchB#switchport mode trunk
accessswitchB#channel-protocol lacp
accessswitchB#channel-group 3 mode passive
accessswitchB#interface GigabitEthernet1/2
accessswitchB#description * Trunk to Core Switch B (Gi 1/4) *
accessswitchB#switchport trunk encapsulation dot1q
accessswitchB#switchport trunk allowed vlan (List your VLANS)
accessswitchB#end

accessswitchC#Config t
accessswitchC#interface GigabitEthernet1/1
accessswitchC#description * Trunk to Core Switch A (Gi 1/5) *
accessswitchC#switchport trunk encapsulation dot1q
accessswitchC#switchport trunk allowed vlan (List your VLANS)
accessswitchC#switchport mode trunk
accessswitchC#channel-protocol lacp
accessswitchC#channel-group 4 mode passive
accessswitchC#interface GigabitEthernet1/2
accessswitchC#description * Trunk to Core Switch B (Gi 1/5) *
accessswitchC#switchport trunk encapsulation dot1q
accessswitchC#switchport trunk allowed vlan (List your VLANS)
accessswitchC#end
0
 
LVL 12

Author Comment

by:ibu1
Comment Utility
Hello Rcaballerojr,
We have requirement to connect HP Flex with 10 GB Uplink to core switch. The distance will be maximum 7 meter between them. We are going to use Cisco Catalyst 3850 24 Port as core and Catalyst 2960S 48 GigE as Access switch.For connecting 10 GB HP Flex, we  need one more slot iof 10 GB chassis in each of the Cisco Core 3850 switch and 4 10 GB SFP module.
Thanks for your previous answer. It is so precise.
0
Zoho SalesIQ

Hassle-free live chat software re-imagined for business growth. 2 users, always free.

 
LVL 10

Expert Comment

by:Rafael
Comment Utility
I do have a question now that I know what type switches you have. What is preventing you from stacking the access switches? Are they in different locations?.

On the 3850's looks like you would need a pair of 2 x 10 Gigabit Ethernet with SFP. One for each core switch.  According to the Cisco site. You are needing 2 each C3850-NM-2-10G. You would have to confirm with your vendor. However, here is the link to the 3850's Spec Sheet.  The previous link to that cable site should get you what you need as SFP to SFP.  I would suggest the 10m since they are 7m apart you have to allow for cabling up and down the racks, the cable tray, etc.

Let me know if this helps.
-Rafael
0
 
LVL 12

Author Comment

by:ibu1
Comment Utility
As I have no deep knowledge of cisco device, I don't know the meaning of stacking the switches? All switch are located in the server room itself in a same rack. The previous comment regarding the SFP to SFP, I didn't understand.
Thanks
0
 
LVL 12

Author Comment

by:ibu1
Comment Utility
OK. after googling around, I found that stacking switch means the whole bundle. We previously had Cisco catalyst switch 4006. Before few days some thing happened to switch and 1 or 2 out of 5 got corrupted. Even until now, we are unable to find the proper cause. So to connect the client PC of the whole building we purchase Dlink unmanageable switch. Thanks.
0
 
LVL 10

Expert Comment

by:Rafael
Comment Utility
Stacking allows you to place the switches into one logical unit for as opposed to three separate devices.  This link from the Cisco web site for your 2960s shows more information about this. See page 16 for a good example.

There are some key things to consider when doing this. However, by stacking them you will gain back four ports from my previous config.  Read the article and let me know if you rather stack them.
0
 
LVL 12

Author Comment

by:ibu1
Comment Utility
I don't think the management will go for stack switch as all are worried about what happened previously.
Thanx.
0
 
LVL 10

Expert Comment

by:Rafael
Comment Utility
Got it. Hopefully, what I've given you has helped out. :)
0
 
LVL 12

Author Comment

by:ibu1
Comment Utility
Hi Rafael ,
Thanks for all of your answers.
0
 
LVL 21

Expert Comment

by:Rick_O_Shay
Comment Utility
You accepted an answer that was exactly what I answered to you ORIGINAL question "Yes, you can do this without the SFP's and just use Copper" and didn't share the points. Very disappointing.
0

Featured Post

New My Cloud Pro Series - organize everything!

With space to keep virtually everything, the My Cloud Pro Series offers your team the network storage to edit, save and share production files from anywhere with an internet connection. Compatible with both Mac and PC, you're able to protect your content regardless of OS.

Join & Write a Comment

Suggested Solutions

There are times where you would like to have access to information that is only available from a different network. This network could be down the hall, or across country. If each of the network sites have access to the internet, you can create a ne…
In the world of WAN, QoS is a pretty important topic for most, if not all, networks. Some WAN technologies have QoS mechanisms built in, but others, such as some L2 WAN's, don't have QoS control in the provider cloud.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

728 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

15 Experts available now in Live!

Get 1:1 Help Now