Solved

MAPI over HTTP in Exchange 2013 SP1

Posted on 2014-04-23
4
1,348 Views
Last Modified: 2014-05-26
Dear All,

I configure MAPI over HTTP in Exchange 2013 SP1, when i try to see the settings, i found:



IISAuthenticationMethods        : {Negotiate}
MetabasePath                    : IIS://Exch-1.dds.net/W3SVC/1/ROOT/mapi
Path                            : C:\Program Files\Microsoft\Exchange Server\V15\FrontEnd\HttpProxy\mapi
ExtendedProtectionTokenChecking : None
ExtendedProtectionFlags         : {}
ExtendedProtectionSPNList       : {}
AdminDisplayVersion             : Version 15.0 (Build 847.32)
Server                          : EXCH-1
InternalUrl                     : https://webmail.dds.com/mapi
InternalAuthenticationMethods   : {Negotiate}
ExternalUrl                     : https://mail.dds.com/mapi
ExternalAuthenticationMethods   : {}
AdminDisplayName                :




I need to understand, does MAPI over Http work from outside throughTMG?

And why there is no authentication settings for external mentioned in the settings? and how to configure it?
  (  ExternalAuthenticationMethods   : {}  )
0
Comment
Question by:Rhala
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
4 Comments
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 40017919
Unless something has been changed, I would doubt TMG and MAPI over HTTP would work correctly, simply because it is something new and TMG doesn't understand it.

Did you test it internally?

Simon.
0
 

Author Comment

by:Rhala
ID: 40018564
no
0
 
LVL 35

Accepted Solution

by:
Bembi earned 500 total points
ID: 40025788
Without having tested it...
All the assistants which where providing the older Exchange publications in ISA / TMG were nothing else then standard rules and settings, preset by the assistant. Although TMG doesn't have an assistant for Exchange 2013 anymore, it is even possible to publish Exchange 2013 over TMG, you just have to set some settings by hand now.
For MAPI over HTTP, I can not really see a reason, why it should not work. Reading the changes from RPC to MAPI over HTTP, I have the imagination it gets easier than more complicate. What I can see hat, that you possibly have to add a new link tranlation path for the mapi folder. So some handy adjustments.

But without any warranty.
0

Featured Post

Online Training Solution

Drastically shorten your training time with WalkMe's advanced online training solution that Guides your trainees to action. Forget about retraining and skyrocket knowledge retention rates.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

After hours on line I found a solution which pointed to the inherited Active Directory permissions . You have to give/allow permissions to the "Exchange trusted subsystem" for the user in the Active Directory...
Check out this step-by-step guide for using the newly updated Experts Exchange mobile app—released on May 30.
A company’s greatest vulnerability is their email. CEO fraud, ransomware and spear phishing attacks are the no1 threat to a company’s security. Cybercrime is responsible for the largest loss of money to companies today with losses projected to r…
There are cases when e.g. an IT administrator wants to have full access and view into selected mailboxes on Exchange server, directly from his own email account in Outlook or Outlook Web Access. This proves useful when for example administrator want…

729 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question