Solved

web Application is not writing logs

Posted on 2014-04-23
3
186 Views
Last Modified: 2014-05-08
I am porting my old web app(jdk 1.5) from oracle server to weblogic app server(jdk 1.6). application works fine but not writing logs, only creates empty file.
0
Comment
Question by:MehtaJasmin
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
3 Comments
 
LVL 35

Expert Comment

by:girionis
ID: 40019357
How do you write the logs? Are you using any logging framework? If yes please specify.
0
 

Author Comment

by:MehtaJasmin
ID: 40019798
yes, here is my property file. this is working on other machine but not mine

###################################################################################
############################## LOG4J PROPERTIES FILE ##############################
###################################################################################

# For DEVELOPMENT uncomment line below and comment all other log4j.rootCategory entry(s)
log4j.rootCategory=INFO,stdout,standardFile
log4j.configCheckDelay=900000
################################## CONSOLE ########################################
log4j.appender.stdout=org.apache.log4j.ConsoleAppender
log4j.appender.stdout.layout=org.apache.log4j.PatternLayout
log4j.appender.stdout.layout.ConversionPattern=[%d{dd MMM yyyy HH:mm:ss}] %-5p [%c{1}] %m%n
log4j.defaultInitOverride=true
################################## STANDARD FILE ##################################
log4j.appender.standardFile=org.apache.log4j.RollingFileAppender
log4j.appender.standardFile.File=C://logs/file.log
log4j.appender.standardFile.MaxFileSize=1000KB
log4j.appender.standardFile.MaxBackupIndex=200
log4j.appender.standardFile.layout=org.apache.log4j.PatternLayout
log4j.appender.standardFile.layout.ConversionPattern=[%d{dd MMM yyyy HH:mm:ss}] %-5p [%c{1}] %m%n
0
 
LVL 35

Accepted Solution

by:
girionis earned 500 total points
ID: 40019832
this is working on other machine but not mine

Do these machines have the same configuration? If not then you will have to look to see what's different between your machine and the other machines.

A few more things you could do

1) Check that you're not using any additional loggers and there's conflict between them.
2) Add "-Dlog4j.debug=true" to the command line that starts the server and see if you notice any errors or warning messages.
0

Featured Post

Optimize your web performance

What's in the eBook?
- Full list of reasons for poor performance
- Ultimate measures to speed things up
- Primary web monitoring types
- KPIs you should be monitoring in order to increase your ROI

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Introduction HyperText Transfer Protocol (http://www.ietf.org/rfc/rfc2616.txt) or "HTTP" is the underpinning of internet communication.  As a teacher of web development I have heard many questions, mostly from my younger students who have come to t…
These days, all we hear about hacktivists took down so and so websites and retrieved thousands of user’s data. One of the techniques to get unauthorized access to database is by performing SQL injection. This article is quite lengthy which gives bas…
Wufoo.com provides powerful tools for surveying targeted groups, and utilizing data from completed surveys to find trends, discover areas of demand or customer expectation, and make business decisions on products or services.
Learn how to set-up PayPal payment integration in your Wufoo form. Allow your users to remit payment through PayPal upon completion of your online form. This is helpful for collecting membership payments, customer payments, donations, and more.

617 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question