• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1063
  • Last Modified:

Windows cannot access the specified device, path or file.

A customer complained that Autoplay was not working when he inserted a CD.  I manage to get that function back, but now when he double clicks the desktop shortcut or the icon in Windows Explorer he gets the error: "Windows cannot access the specified device, path or file. You may not have appropriate permissions to access this item."

If he opens Windows Media Player, the audio works.

The OS is Windows 7 Ultimate.

What do we have to do to get Autoplay to work correctly?
0
rhavey
Asked:
rhavey
  • 3
  • 2
1 Solution
 
jcimarronCommented:
rhavey--
Was AutoPlay working correctly until just recently?  If so run a System Restore to a date before the problem started.
If no help look into the issue of Permissions and Ownership.
http://www.addictivetips.com/windows-tips/windows-7-access-denied-permission-ownership/
0
 
rhaveyAuthor Commented:
This worked until recently.

Thanks for the response.  There is no System Restore Point before today.  I had removed a couple of utilities that seemed to be getting in the way.  I reversed the process because removing them did no good.  Now I am back to a right click bringing up a menu generated by something called ASUS Splendid.  The only thing that might be ASUS in that computer is the video card.  Information on ASUS Splendid is pretty sparse.

I am still in the same situation.  I should have mentioned that when I started I had to repair Windows Media Player.  I also uninstalled iTunes.

After the system restore, I again repaired Windows Media Player.  Now in the right pane of Explorer the error message is "iTunes cannot run because some of its files are missing.  I have done everything I can think of to set the default for the DVD drive and for CDA and CDDA files to Media Player.  I suppose I could reinstall iTunes and call it done, but something is wrong.
0
 
jcimarronCommented:
rhavey--
This tutorial offers two procedures to enable AutoPlay in Win 7
http://www.sevenforums.com/tutorials/216706-autoplay-enable-disable.html
0
 
rhaveyAuthor Commented:
The same customer decided to upgrade to Windows 8.1.  That cured the problem.
0
 
rhaveyAuthor Commented:
I am accepting my own comment to close this question.  We need a better way to close a question when there is no resolution.

In this case I could not make any of the suggestions work.
0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now