Windows 7 Workstation running outlook 2007 shows connected to Exchange but won't receive new mail

Exchange Server 2010

Upgrading a workstation: Old Computer running Windows XP with Outlook 2007 new computer is Windows 7 running outlook 2007.

Problem is it shows connected to Exchange but won't receive new mail.

Before shutting off the xp computer I exported the .pst to the desktop and shut it off
then I connected the win 7 computer and opened outlook connected it to exchange then selected work offline and re-imported the .pst file created earlier. all seemed well until the next day when it wouldn't receive new mail.

I made it ask me for the name and password to make sure all is well there and it is..
DyingLifeAsked:
Who is Participating?
 
Russ SuterConnect With a Mentor Commented:
I've had this happen before.

If you're connected to an Exchange server using the Exchange service (and not POP or IMAP) then Outlook actually doesn't use a .pst file. It uses a .ost file instead which is really just a local copy of what's on the server.

I've almost always managed to fix this issue by locating the .ost file and renaming it (something like outlook.ost.bad). Then when you relaunch Outlook it will simply rebuild a new .ost file from the server.

Of course, you'll need to make sure Outlook is properly shut down before renaming the file.

The .ost file is typically found in <systemdrive>:\Users\<user>\AppData\Local\Microsoft\Outlook

Although if you're using XP it's probably in the Documents and Settings folder but the path should be similar other than that.

You will need to make sure your Windows Explorer has the "show hidden files and folders" option enabled.
0
 
DyingLifeAuthor Commented:
when trying to rename the
outlook0.ost file I receive an error

this cannot be completed because the file is open in search protocol host
0
 
Russ SuterCommented:
That means Outlook is either running or has been recently running and hasn't shut down properly (which Outlook is prone to do from time to time).

Restart the computer and rename the file before launching Outlook.
0
 
DyingLifeAuthor Commented:
tried restarting it didn't work same message

I did a quick google search http://www.howtogeek.com/forum/topic/searchprotocolhostexe-is-reading-every-file-on-my-hard-disk-what-is-it

and saw to disable indexing for the drive which worked.

file renamed from

outlook0.ost to outlook0.ost.bad

it now re-created the file and named it outlook.ost as you mentioned it would and now its pulling in the new mail thanks!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.