post domain integral

I received this email today. Has anyone ever seem anything like this or know where and why it is originating?


*******

Dear Sirs,

I am administrator of post domain integral.by and we have a little problems:

Your post server (kmgchemicals.com) should indicate the name of existent domain when messages delivery in command HELO (in accordance with document http://www.ietf.org/rfc/rfc2821.txt), but your server sends "xxx-xxx-xxx and out domain" - this is incorrect value, and our post server refuse to accept messages from your post server (because this is a kind of additional SPAM protection).
Could you please correct this little inaccuracy in a setting of post server.

Best regards,
Administrator of post domain integral.by


Best regards,
Ryhor
LVL 1
Group_007Asked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
Jamie McKillopConnect With a Mentor IT ManagerCommented:
Hello,

You need to set the FQDN on your send connector to match the public A record of your server. You can do that with the following powershell command:

Set-SendConnector "<Send connector name>" -fqdn "<public FQDN>"

-JJ
0
 
kevinhsiehCommented:
It looks to me like they are telling you that your mail server is incorrectly configured and that it should be corrected  before they will accept mail from you.
0
 
jrhelgesonCommented:
Well, the mx record for kmgchemicals.com points to data1.kmgbernuth.com.
data1.kmgbernuth.com resolves to 70.42.5.161 for both forward and reverse DNS lookups.

When I telnet to data1.kmgbernuth.com on port 25, I get:
220 barracuda.kmgchemicals.com ESMTP (24f803607f621552a38e5a6f642de7f4)

Open in new window


I look at the SPF record for your domain and I can see it set to "v=spf1 mx ~all"

This is pretty lax on the SPF record scale - in fact, it's just saying "SPF records are a joke, and just accept email from any mail server that pretends to be us"

None of this should have any impact on your ability to send mail to a customer, unless your outbound mail leaves your network on an IP address that is different than the one used for inbound.  If this is the case, you'll need to set up reverse DNS for that IP as well.

Otherwise, I'll need to see what your mail server is actually displaying in the connect string, and what they say actually needs to be in your connect string in order to make everyone happy.
0
 
Group_007Author Commented:
Thank you for the details. I was quickly able to view the current setting's for the default send connector; which had no entry.

Toni
0
All Courses

From novice to tech pro — start learning today.