Cyrstal Reports 2008 seeing SQL Server DATE field as STRING

I have a crystal report that in 2008 see's the DATE field as a STRING. However, if I open the report using Crystal report 11.5 it shows it correctly as a DATE Field.

Our server version is 2008 which is why i need to get this fixed and my formulas are not working since it now sees as STRING.

Any ideas?
kelsanitAsked:
Who is Participating?
 
mebaby333Connect With a Mentor It AdminCommented:
It is in the sql 2008 feature pack..... you can download it if you do not have the disk here..
http://www.microsoft.com/en-us/download/confirmation.aspx?id=16978

here is a technet article on installing it
http://technet.microsoft.com/en-us/library/ms131321%28v=sql.105%29
0
 
mebaby333It AdminCommented:
did you try just formating the field as a date? right click on the box and choose format
0
 
mebaby333It AdminCommented:
Or is there something in particular you are trying to do to it that is being prevented?
0
The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

 
vastoCommented:
Verify the database
0
 
kelsanitAuthor Commented:
yes, I have verified the database.  I have even created a brand new report on the 2008 version with just that one table and it shows as STRING.  

I dont want to format as then it want work in the 11.5 version.

there has to be a setting in the options or just service pack fix for this. Currently on 12.4.0.966
0
 
vastoCommented:
Are you using a view or stored procedure ?
0
 
mebaby333It AdminCommented:
Did you try and confirm it would not work right in the 11.5 version?
0
 
kelsanitAuthor Commented:
I am using ODBC SQL driver and connecting directly to table.  No I did not verify it woudl not work in 11.5 if I format the field.
0
 
mlmccCommented:
What version of Crystal was the report built in?

Try opening it is CR XI then saving to a NEW report name

mlmcc
0
 
vastoCommented:
when you verify the database the report will detect that the field is different and will ask you to map it to another field. Did you see anything like this ?
0
 
kelsanitAuthor Commented:
yes, when I open in 2008 it has be map. Of coure it does not find as same type and I have to map to string field.
0
 
vastoCommented:
When you see the map button you should uncheck the check box for the type. Then you will see the date field. If you map the field to a string field it will assume it is string
0
 
mebaby333It AdminCommented:
change the  ODBC connection  to SQL SERVER NATIVE CLIENT 10.
0
 
mebaby333It AdminCommented:
The new SQL Server connection type is an updated driver that older versions of Crystal Reports do not recognize
0
 
kelsanitAuthor Commented:
currently i only see SQL Server as an option on the server.

how do i get option for NATIVE SQL server client?
0
All Courses

From novice to tech pro — start learning today.