Solved

Access shared folder in another domain

Posted on 2014-04-25
7
486 Views
Last Modified: 2014-04-25
I have a file server (Win 2008 Enterprise R2) in DOMAIN-A which holds a share named SHARE-A.
In DOMAIN-B all the users are located.
There is a Trust relasionship (two-way) between DOMAIN-A and DOMAIN-B.

I have given DOMAIN-B\USER-B Full Controll Permissions to SHARE-A (both NTFS and share permissions).

When USER-B tries to access the share (\\domain-a\share-a) he can se the folder and its contents, but though he has Full Controll permissions, he can't add new files (Destination Folder Access Denied).

What am I doing wrong here?
0
Comment
Question by:Kasper Katzmann
  • 3
  • 3
7 Comments
 

Expert Comment

by:FF-ExEx
ID: 40022494
From what you are descirbing everything looks good and it should work. I would make sure that no other permissions are present at share or folder (NTFS) level espacially no deny permission at NTFS level because this would overwrite every allow permission.
0
 

Author Comment

by:Kasper Katzmann
ID: 40022530
My thoughts exactly.
It's a completely new file server and the only permissions set after installation are those descibed above. There are no deny permissions at all.
0
 

Expert Comment

by:FF-ExEx
ID: 40022556
Ok, since this are two domains you should make sure that this is at least working for users from domain a. Setup the same permissions for a user from domain a and check if this working.

If this is also not working can you post screenshots about the configured permissions?
0
Back Up Your Microsoft Windows Server®

Back up all your Microsoft Windows Server – on-premises, in remote locations, in private and hybrid clouds. Your entire Windows Server will be backed up in one easy step with patented, block-level disk imaging. We achieve RTOs (recovery time objectives) as low as 15 seconds.

 

Author Comment

by:Kasper Katzmann
ID: 40022575
Oops... same problem with a local domain account. Why...? I ask my self...
0
 

Expert Comment

by:FF-ExEx
ID: 40022597
Difficult to help from here without seeing what exactly is set. A few screenshots with the set permissions would help.
0
 
LVL 12

Accepted Solution

by:
Sandeep earned 500 total points
ID: 40022619
If both NTFS and share permissions are defined correctly but still not working?

I would say remove those permissions and add those back. Also while adding make sure you choosing the option to replicate\propogate the change to child objects. So these permissions gets applied in same manner down the line.

See if this works.
0
 

Author Closing Comment

by:Kasper Katzmann
ID: 40023856
Of course, inheritable permissions. So simple that I missed it. Thanks for pointing it out for me.
0

Featured Post

Comprehensive Backup Solutions for Microsoft

Acronis protects the complete Microsoft technology stack: Windows Server, Windows PC, laptop and Surface data; Microsoft business applications; Microsoft Hyper-V; Azure VMs; Microsoft Windows Server 2016; Microsoft Exchange 2016 and SQL Server 2016.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

While rebooting windows server 2003 server , it's showing "active directory rebuilding indices please wait" at startup. It took a little while for this process to complete and once we logged on not all the services were started so another reboot is …
This article runs through the process of deploying a single EXE application selectively to a group of user.
This tutorial will give a an overview on how to deploy remote agents in Backup Exec 2012 to new servers. Click on the Backup Exec button in the upper left corner. From here, are global settings for the application such as connecting to a remote Back…
This video shows how to use Hyena, from SystemTools Software, to bulk import 100 user accounts from an external text file. View in 1080p for best video quality.

831 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question