Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Apply Cisco QoS to outside interface

Posted on 2014-04-25
3
Medium Priority
?
1,031 Views
Last Modified: 2014-04-25
I have a new cisco 891 router that I am trying to configure for QoS.

I have some experience with cisco ios just not qos.

What I am trying to accomplish is to guarantee at least 2mbps bandwidth to the VoIP vlan and limit a guest vlan to 2mbps maximum. There are other vlans and they should have the remaining bandwidth.

I configured class maps and policy maps as follows:

class-map match-any guest-class-map
 match access-group 40
class-map match-any voice-class-map
 match access-group 20
!
policy-map default-policy
 class class-default
  bandwidth remaining percent 100
policy-map voice-traffic
 class voice-class-map
  bandwidth 2048
policy-map guest-traffic
 class guest-class-map
  police cir 2097000
   exceed-action drop
!

access-list 20 permit 10.3.99.0 0.0.0.255
access-list 40 permit 10.6.99.0 0.0.0.255

I believe these are correct for what I am looking to accomplish. Correct me if they are not.

The question I have is how to apply these policies to my outside interface?

It only allows me to attach one policy to output.

It does not allow me to attach any to input. Says bandwidth command not allowed at parent level in input direction.
0
Comment
Question by:bts86
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
3 Comments
 
LVL 6

Accepted Solution

by:
Hassan Besher earned 2000 total points
ID: 40023200
At VOIP you should implement priority  not Bandwidth :

policy-map LLQ
 class voice-class-map
  priority  2048

 class guest-class-map
  police cir 2097000
   exceed-action drop

class class-default
  fair-queue

interface
service-policy output LLQ
0
 
LVL 1

Author Comment

by:bts86
ID: 40023332
Ok, I will try that.

I have a question about priority, it is unclear to me in cisco's documentation.

If i allocate 2048K to the voice class, is that bandwidth still available to the default class if it is not being used? And can the voice class utilize more bandwidth if it needs to?
0
 
LVL 6

Expert Comment

by:Hassan Besher
ID: 40023536
your priority option will make sure that you have the specific bandwidth you say and not more also it will make sure to always put voip traffic in the first of the queue (Strict queue).
0

Featured Post

Fill in the form and get your FREE NFR key NOW!

Veeam® is happy to provide a FREE NFR server license to certified engineers, trainers, and bloggers.  It allows for the non‑production use of Veeam Agent for Microsoft Windows. This license is valid for five workstations and two servers.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Originally, this post was published on Monitis Blog, you can check it here . It goes without saying that technology has transformed society and the very nature of how we live, work, and communicate in ways that would’ve been incomprehensible 5 ye…
This article will show how Aten was able to supply easy management and control for Artear's video walls and wide range display configurations of their newsroom.
If you're a developer or IT admin, you’re probably tasked with managing multiple websites, servers, applications, and levels of security on a daily basis. While this can be extremely time consuming, it can also be frustrating when systems aren't wor…
Michael from AdRem Software outlines event notifications and Automatic Corrective Actions in network monitoring. Automatic Corrective Actions are scripts, which can automatically run upon discovery of a certain undesirable condition in your network.…
Suggested Courses

715 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question