• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 300
  • Last Modified:

SBS2008 no external connectivity every startup, must run Fix Network wizard

I think probably from installing an update (and I wouldn't know which one), or from trying to set up a Smart Host (which I have now removed as it was a bottleneck nightmare and corrupting my Exchange transport), every time I restart the server, there is no external connectivity until I run Fix My Network wizard.

It states I have an incorrect network address type, and it goes away setting my server a fixed IP address.  I know that my IPv4 and v6 addresses are static, and they are static even after start up, and before I run the wizard.  My guess is a DNS issue, but don't take my word for it.

Thank you
0
andrewjs
Asked:
andrewjs
  • 3
1 Solution
 
Gareth GudgerCommented:
If you ping www.google.com for example does it resolve?

Rather than run Fix My Network, what happens if you try a IPCONFIG /FLUSHDNS from the server? Also, go into DNS Manager, right click the server name and select "Clear Cache".
0
 
andrewjsAuthor Commented:
Thank you,
I have tried the Clear Cache in DNS, and I will test the scenario later today.
I don't think that external DNS would resolve under this lack of connectivity.
Obviously my trouble is I have to be at work out of hours to try.
0
 
ronnypotCommented:
Hi,

This is a know issue with SBS 2008 issue, it will loose its default gateway after a reboot. The problem is that there is a empty line in the HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\<GUID>\DefaultGateway registry key. Removing this line will solve the problem.

full solution is in the article: http://blogs.technet.com/b/sbs/archive/2010/04/22/you-may-lose-the-default-gateway-on-sbs-2008-every-time-you-reboot.aspx
0
 
andrewjsAuthor Commented:
Thank you for that info.
Certainly describes the situation.
I have applied the changes, but will wait to restart to test, really appreciate the advice.
0
 
andrewjsAuthor Commented:
All fixed thanks.  I had to re-enter the gateway ip afterward, don't know why, it seemed fine in the registry setting, but it worked - thanks.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now