How do I tell Dovecot and Sendmail to use the Same Directory for User Email

Greetings All,

Well this is the third question in a series of questions about POP3 and Email retrieval on CentOS.


The First 2 have been answered and I now have Password Authentication working as well as the ability to send mail to the server for individual users. Thanks Ian and Sandy..

My problem now is How do I get Sendmail and Dovecot to use the same 'Folder/directory' for email. Sendmail wants to put it in /var/mail<username> where <username> is an actual file and Dovecot want to look for email in the users /home directory... not a file.

Oh... and leaving mail_location blank did not work either. If you can tell me how to make that work I would use that..


I have tied to modify /etc/login.defs and /etc/dovecot/conf.d/10-mail.conf but I have not yet found a 'combination' that works.


As always thanks in advance for any help you can give me..  BTW please provide and example as I read and tried different combinations until I am blue in the face... :)

Rick
LVL 2
rrbeckerAsked:
Who is Participating?
 
rrbeckerConnect With a Mentor Author Commented:
OK.. this was the final step that got things working...

namespace {
  separator = /
  prefix = "#mbox/"
  location = mbox:~/mail:INBOX=/var/mail/%u
  inbox = yes
  hidden = yes
  list = no
}
namespace {
  separator = /
  prefix =
  location = maildir:~/Maildir
}
0
 
rrbeckerAuthor Commented:
Hi All...

here is part of an error message that is reported in /var/log/maillog.

-----------------------------------------------------------------------------------------------
Apr 28 07:36:01 ip-50-62-164-110 dovecot: pop3(rrb): Error: chown(/home/rrb/mail/.imap/INBOX, -1, 12(mail)) failed: Operation not permitted (egid=502(rrb), group based on /var/mail/rrb)
Apr 28 07:36:01 ip-50-62-164-110 dovecot: pop3(rrb): Error: mkdir(/home/rrb/mail/.imap/INBOX) failed: Operation not permitted
----------------------------------------------------------------------------------------------------

As you can see it is complaining Goup level permissions and Group ID. How do I resolve this issue.. I think this will take care of my needs..

Is there a setting that I need to set which allows Chroot??

Rick
0
 
rrbeckerAuthor Commented:
No other experts were involved in this solution...
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.