DNS Outlook Issues

I host exchange in house.  As I am adding outlook 2013 clients I am running into problems with DNS that I have never had before.  Outlook is trying to pull the external IP address of the exchange machine so the clients will not connect.  After a 5-10 minutes the outlook client will connect.  I have removed the external entries from DNS, however, the external addresses keep adding themselves back into dns.  Any advice to resolve this issue?
dcitdirAsked:
Who is Participating?
 
bmurray-vbConnect With a Mentor Commented:
Sounds like it could be one of a few different issues.

Do you have all of your exchange virtual directories setup properly with the correct internal and external values?

Something that I always do when deploying exchange is I create an authoritative internal zone for the mail domain.

To do so, you need to first create an internal authoritative domain for yourexternaldomainname.com in your DNS server (on your domain controller, Administrative Tools -> DNS -> Forward Lookup Zones -> New Zone -> Primary Zone), and then create entries for autodiscover, www, mail, etc in this zone. Use the local IP addresses for these entries. This will become authoritative for inside of your network (and, obviously, ONLY for your internal network, as this DNS zone would not synchronize upstream).
0
 
dcitdirAuthor Commented:
I have all the entries for autodiscover, www, mail, etc in a zone already with the local ip addresses.
0
 
bmurray-vbCommented:
Do you have all of your exchange virtual directories setup properly with the correct internal and external values?

If so, try to create a new profile on a workstation to see what the behavior looks like after the new profile is generated.

Start - Run - Outlook.exe /profiles   to create a new profile and see what's going on.

Check autoconfiguration and connectivity status by holding down the ctl key and right clicking on the outlook system tray icon

Also, ping the FQDN of the mail server from the local workstation to see what it is seeing as an IP address for the host.
0
Improved Protection from Phishing Attacks

WatchGuard DNSWatch reduces malware infections by detecting and blocking malicious DNS requests, improving your ability to protect employees from phishing attacks. Learn more about our newest service included in Total Security Suite today!

 
Simon Butler (Sembee)ConsultantCommented:
You probably don't have the virtual directories setup correctly - not all of them can be done through the GUI.
Check with my article here: http://semb.ee/hostnames

Then do an Autodiscover test http://semb.ee/adt and see what is being returned to the client by Exchange. Autodiscover isn't really an optional feature and if you have the information wrong then it can try and use an external host name.

If you have the external host name in the SSL certificate then you will need a split DNS.

Of course, if you are using Exchange 2003 then Outlook 2013 isn't a supported client and all of the above is null.

Simon.
0
 
hecgomrecCommented:
Sorry to say this but if you are having clients looking for your in premises exchange server outside your network by creating a new profile, this means you don't have the proper A and/or MX records or any other setup on your DNS servers.  Otherwise the client will find it without going out your LAN.

Are you able to open OWA using your "hostname" from your LAN? (https://yourmail.server.com)

Are you able to access your OWA using a phone connected to its carrier data? (not using your LAN)
0
 
dcitdirAuthor Commented:
I found the issue.  In dns somehow one of the external addresses was checked in the interfaces.  Once I unchecked the external interface everything started working properly.
0
 
dcitdirAuthor Commented:
Thanks this led me in the direction of finding the issue.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.