Java 2SE 5.0 msi removal

Hello, I now have Java 1.6 and 1.8 installed.  I need to have 1.5 as well, yet I can't run/install the jdk-1_5_0_22-windows-i586-p.  When I run it, it tell me that it is there, yet it isn't because I deleted it.    It tells me it can't open the package.

I hate to have to remove 1.6 and 1.8, to install 1.5.

After removing 1.6 and 1.8 and rebooting, I ran jdk-1_5_0_22-windows-i586-p.exe, this loads a copy of the J2SE Development Kit 5.0 Update 22.msi, but then a pop-up message indicates;
Windows installer
This installation package could not be opened. Contact the application vendor…

Any suggestions, comments?  I'll go try disabling 1.6 and 1.8.
Who is Participating?
Gibu GeorgeConnect With a Mentor Chief Technology OfficerCommented:
I think the installer got corrupted and it has nothing to do with having other versions of java. I think what you need to do is freshly download jdk 1.5 and try to install again.
ValeriConnect With a Mentor Commented:
chimaAuthor Commented:
valeri, thanks,
George, correct - I had to manually start the Windows Installer Service and then I was able to install 1.5.
I'll issue the points shortly.
chimaAuthor Commented:
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.