Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2402
  • Last Modified:

SCCM 2012

Hi all, I am new to SCCM 2012, I have just installed it in my lab env't - running on Windows 2008 R2, and the  SQL is 2012 r2 .

The install went fine, I am having issues with the following
1. Client will NOT install to a Windows 7 Pro PC, the devices are listed I right click it and say install it goes through the process but the client never gets installed on the Win7 Pro PC
2. Software Library - All software updates - have tried synchronized software updates button a few times, waiting a few days and still shows No items Found.
0
nutekconsultant
Asked:
nutekconsultant
  • 4
  • 2
  • 2
3 Solutions
 
Darrell PorterEnterprise Business Process ArchitectCommented:
Have you looked at this Microsoft blog entry -

http://blogs.technet.com/b/sudheesn/archive/2010/05/31/troubleshooting-sccm-part-i-client-push-installation.aspx

Are there any errors in the ccm.log file?

Are the credentials correctly configured and are they a local admin on the client machine in question?
0
 
nutekconsultantAuthor Commented:
here is some of the log file.....the latest logs.


======>Begin Processing request: "2097152003", machine name: "WIN7"  $$<SMS_CLIENT_CONFIG_MANAGER><04-28-2014 15:38:46.754+240><thread=2860 (0xB2C)>
Execute query exec [sp_IsMPAvailable] N'123'~  $$<SMS_CLIENT_CONFIG_MANAGER><04-28-2014 15:38:46.756+240><thread=2860 (0xB2C)>
---> Trying each entry in the SMS Client Remote Installation account list~  $$<SMS_CLIENT_CONFIG_MANAGER><04-28-2014 15:38:46.762+240><thread=2860 (0xB2C)>
---> Attempting to connect to administrative share '\\WIN7\admin$' using account 'TEST\admin'~  $$<SMS_CLIENT_CONFIG_MANAGER><04-28-2014 15:38:46.762+240><thread=2860 (0xB2C)>
---> Connected to administrative share on machine WIN7 using account 'TEST\admin'~  $$<SMS_CLIENT_CONFIG_MANAGER><04-28-2014 15:38:46.798+240><thread=2860 (0xB2C)>
---> Attempting to make IPC connection to share <\\WIN7\IPC$> ~  $$<SMS_CLIENT_CONFIG_MANAGER><04-28-2014 15:38:46.798+240><thread=2860 (0xB2C)>
---> Searching for SMSClientInstall.* under '\\WIN7\admin$\'~  $$<SMS_CLIENT_CONFIG_MANAGER><04-28-2014 15:38:46.800+240><thread=2860 (0xB2C)>
---> System OS version string "6.1.7601" converted to 6.10  $$<SMS_CLIENT_CONFIG_MANAGER><04-28-2014 15:38:46.972+240><thread=2860 (0xB2C)>
---> Unable to connect to WMI (root\ccm) on remote machine "WIN7", error = 0x8004100e.  $$<SMS_CLIENT_CONFIG_MANAGER><04-28-2014 15:38:46.988+240><thread=2860 (0xB2C)>
---> Creating \ VerifyingCopying exsistance of destination directory \\WIN7\admin$\ccmsetup.~  $$<SMS_CLIENT_CONFIG_MANAGER><04-28-2014 15:38:46.992+240><thread=2860 (0xB2C)>
---> Copying client files to \\WIN7\admin$\ccmsetup.~  $$<SMS_CLIENT_CONFIG_MANAGER><04-28-2014 15:38:47.000+240><thread=2860 (0xB2C)>
---> Copying file "C:\Program Files\Microsoft Configuration Manager\bin\I386\MobileClient.tcf" to "MobileClient.tcf"  $$<SMS_CLIENT_CONFIG_MANAGER><04-28-2014 15:38:47.001+240><thread=2860 (0xB2C)>
---> Copying file "C:\Program Files\Microsoft Configuration Manager\bin\I386\ccmsetup.exe" to "ccmsetup.exe"  $$<SMS_CLIENT_CONFIG_MANAGER><04-28-2014 15:38:47.028+240><thread=2860 (0xB2C)>
---> Updated service "ccmsetup" on machine "WIN7".  $$<SMS_CLIENT_CONFIG_MANAGER><04-28-2014 15:38:47.066+240><thread=2860 (0xB2C)>
---> Started service "ccmsetup" on machine "WIN7".  $$<SMS_CLIENT_CONFIG_MANAGER><04-28-2014 15:38:47.095+240><thread=2860 (0xB2C)>
---> Deleting SMS Client Install Lock File '\\WIN7\admin$\SMSClientInstall.123'~  $$<SMS_CLIENT_CONFIG_MANAGER><04-28-2014 15:38:47.099+240><thread=2860 (0xB2C)>
Execute query exec [sp_CP_SetLastErrorCode] 2097152003, 0~  $$<SMS_CLIENT_CONFIG_MANAGER><04-28-2014 15:38:47.118+240><thread=2860 (0xB2C)>
---> Completed request "2097152003", machine name "WIN7".  $$<SMS_CLIENT_CONFIG_MANAGER><04-28-2014 15:38:47.120+240><thread=2860 (0xB2C)>
Deleted request "2097152003", machine name "WIN7"  $$<SMS_CLIENT_CONFIG_MANAGER><04-28-2014 15:38:47.121+240><thread=2860 (0xB2C)>
Execute query exec [sp_CP_SetPushRequestMachineStatus] 2097152003, 4~  $$<SMS_CLIENT_CONFIG_MANAGER><04-28-2014 15:38:47.121+240><thread=2860 (0xB2C)>
Execute query exec [sp_CP_SetLatest] 2097152003, N'04/28/2014 19:38:47', 8~  $$<SMS_CLIENT_CONFIG_MANAGER><04-28-2014 15:38:47.123+240><thread=2860 (0xB2C)>
<======End request: "2097152003", machine name: "WIN7".  $$<SMS_CLIENT_CONFIG_MANAGER><04-28-2014 15:38:47.126+240><thread=2860 (0xB2C)>
Getting a new request from queue "Retry" after 100 millisecond delay.  $$<SMS_CLIENT_CONFIG_MANAGER><04-28-2014 15:41:44.498+240><thread=3420 (0xD5C)>
Sleeping for 60 minutes for queue "Retry".  $$<SMS_CLIENT_CONFIG_MANAGER><04-28-2014 15:41:44.499+240><thread=3420 (0xD5C)>
0
 
merowingerCommented:
Have you configured a Client Push Installation Account which has local Admin permissons on the Clients?
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
nutekconsultantAuthor Commented:
I'm logged into the sccm server with domain\admin.  I'm also logged into the windows 7 PC with same account.   On the windows 7 PC I have added the domain admin account to local admin group....
0
 
merowingerCommented:
0
 
Darrell PorterEnterprise Business Process ArchitectCommented:
Actually, considering you're receiving WMI error 0x8004100e because root\ccm does not exist,

Ideally, you should have a non-domain admin account which does have administrative permissions on all local machines for which you wish to push the client.  Perhaps create a "SCCM_ADMIN" account and push out local administrators permissions for all the client machines.

Once this is done, then attempt the push of the client using this SCCM_ADMIN account.
0
 
nutekconsultantAuthor Commented:
ok i tried with the above post - it is making some headway....on the client in task manager - I see the ccmsetup.exe showing up for the first time...

but it still fails... here is the ccm.log


======>Begin Processing request: "2097152003", machine name: "WIN7"  $$<SMS_CLIENT_CONFIG_MANAGER><04-30-2014 12:00:20.358+240><thread=4636 (0x121C)>
Execute query exec [sp_IsMPAvailable] N'123'~  $$<SMS_CLIENT_CONFIG_MANAGER><04-30-2014 12:00:20.360+240><thread=4636 (0x121C)>
---> Trying each entry in the SMS Client Remote Installation account list~  $$<SMS_CLIENT_CONFIG_MANAGER><04-30-2014 12:00:20.364+240><thread=4636 (0x121C)>
---> Attempting to connect to administrative share '\\WIN7\admin$' using account 'TEST\bob'~  $$<SMS_CLIENT_CONFIG_MANAGER><04-30-2014 12:00:20.365+240><thread=4636 (0x121C)>
---> Connected to administrative share on machine WIN7 using account 'TEST\bob'~  $$<SMS_CLIENT_CONFIG_MANAGER><04-30-2014 12:00:20.664+240><thread=4636 (0x121C)>
---> Attempting to make IPC connection to share <\\WIN7\IPC$> ~  $$<SMS_CLIENT_CONFIG_MANAGER><04-30-2014 12:00:20.664+240><thread=4636 (0x121C)>
---> Searching for SMSClientInstall.* under '\\WIN7\admin$\'~  $$<SMS_CLIENT_CONFIG_MANAGER><04-30-2014 12:00:20.676+240><thread=4636 (0x121C)>
---> System OS version string "6.1.7601" converted to 6.10  $$<SMS_CLIENT_CONFIG_MANAGER><04-30-2014 12:00:21.792+240><thread=4636 (0x121C)>
---> Unable to connect to WMI (root\ccm) on remote machine "WIN7", error = 0x8004100e.  $$<SMS_CLIENT_CONFIG_MANAGER><04-30-2014 12:00:21.864+240><thread=4636 (0x121C)>
---> Creating \ VerifyingCopying exsistance of destination directory \\WIN7\admin$\ccmsetup.~  $$<SMS_CLIENT_CONFIG_MANAGER><04-30-2014 12:00:21.883+240><thread=4636 (0x121C)>
---> Copying client files to \\WIN7\admin$\ccmsetup.~  $$<SMS_CLIENT_CONFIG_MANAGER><04-30-2014 12:00:21.932+240><thread=4636 (0x121C)>
---> Copying file "C:\Program Files\Microsoft Configuration Manager\bin\I386\MobileClient.tcf" to "MobileClient.tcf"  $$<SMS_CLIENT_CONFIG_MANAGER><04-30-2014 12:00:21.940+240><thread=4636 (0x121C)>
---> Copying file "C:\Program Files\Microsoft Configuration Manager\bin\I386\ccmsetup.exe" to "ccmsetup.exe"  $$<SMS_CLIENT_CONFIG_MANAGER><04-30-2014 12:00:22.101+240><thread=4636 (0x121C)>
Submitted request successfully  $$<SMS_CLIENT_CONFIG_MANAGER><04-30-2014 12:00:22.359+240><thread=3896 (0xF38)>
Getting a new request from queue "Incoming" after 100 millisecond delay.  $$<SMS_CLIENT_CONFIG_MANAGER><04-30-2014 12:00:22.360+240><thread=3896 (0xF38)>
Waiting for change in directory "C:\Program Files\Microsoft Configuration Manager\inboxes\ccr.box" for queue "Incoming", (30 minute backup timeout).  $$<SMS_CLIENT_CONFIG_MANAGER><04-30-2014 12:00:22.362+240><thread=3896 (0xF38)>
---> Updated service "ccmsetup" on machine "WIN7".  $$<SMS_CLIENT_CONFIG_MANAGER><04-30-2014 12:00:22.449+240><thread=4636 (0x121C)>
---> Started service "ccmsetup" on machine "WIN7".  $$<SMS_CLIENT_CONFIG_MANAGER><04-30-2014 12:00:22.691+240><thread=4636 (0x121C)>
---> Deleting SMS Client Install Lock File '\\WIN7\admin$\SMSClientInstall.123'~  $$<SMS_CLIENT_CONFIG_MANAGER><04-30-2014 12:00:22.701+240><thread=4636 (0x121C)>
Execute query exec [sp_CP_SetLastErrorCode] 2097152003, 0~  $$<SMS_CLIENT_CONFIG_MANAGER><04-30-2014 12:00:22.807+240><thread=4636 (0x121C)>
---> Completed request "2097152003", machine name "WIN7".  $$<SMS_CLIENT_CONFIG_MANAGER><04-30-2014 12:00:22.813+240><thread=4636 (0x121C)>
Deleted request "2097152003", machine name "WIN7"  $$<SMS_CLIENT_CONFIG_MANAGER><04-30-2014 12:00:22.814+240><thread=4636 (0x121C)>
Execute query exec [sp_CP_SetPushRequestMachineStatus] 2097152003, 4~  $$<SMS_CLIENT_CONFIG_MANAGER><04-30-2014 12:00:22.823+240><thread=4636 (0x121C)>
Execute query exec [sp_CP_SetLatest] 2097152003, N'04/30/2014 16:00:22', 26~  $$<SMS_CLIENT_CONFIG_MANAGER><04-30-2014 12:00:22.837+240><thread=4636 (0x121C)>
<======End request: "2097152003", machine name: "WIN7".  $$<SMS_CLIENT_CONFIG_MANAGER><04-30-2014 12:00:22.842+240><thread=4636 (0x121C)>
The Site Control File has not changed since the last parameter update.  $$<SMS_CLIENT_CONFIG_MANAGER><04-30-2014 12:08:37.777+240><thread=2760 (0xAC8)>
Updating Site Parameters  $$<SMS_CLIENT_CONFIG_MANAGER><04-30-2014 12:08:37.778+240><thread=2760 (0xAC8)>
~MP Ports: 80  $$<SMS_CLIENT_CONFIG_MANAGER><04-30-2014 12:08:37.779+240><thread=2760 (0xAC8)>
~IISPreferedPort: 80  $$<SMS_CLIENT_CONFIG_MANAGER><04-30-2014 12:08:37.779+240><thread=2760 (0xAC8)>
~MP SSL Ports: 443  $$<SMS_CLIENT_CONFIG_MANAGER><04-30-2014 12:08:37.780+240><thread=2760 (0xAC8)>
~IISSSLPreferedPort: 443  $$<SMS_CLIENT_CONFIG_MANAGER><04-30-2014 12:08:37.780+240><thread=2760 (0xAC8)>
~Default MP: WinSCCM.test.local  $$<SMS_CLIENT_CONFIG_MANAGER><04-30-2014 12:08:37.780+240><thread=2760 (0xAC8)>
~Default MP Type: 1  $$<SMS_CLIENT_CONFIG_MANAGER><04-30-2014 12:08:37.781+240><thread=2760 (0xAC8)>
~Default MP: [None]  $$<SMS_CLIENT_CONFIG_MANAGER><04-30-2014 12:08:37.781+240><thread=2760 (0xAC8)>
~Certificate Selection Criteria:   $$<SMS_CLIENT_CONFIG_MANAGER><04-30-2014 12:08:37.782+240><thread=2760 (0xAC8)>
~Certificate Store:   $$<SMS_CLIENT_CONFIG_MANAGER><04-30-2014 12:08:37.782+240><thread=2760 (0xAC8)>
~SSL State: 480  $$<SMS_CLIENT_CONFIG_MANAGER><04-30-2014 12:08:37.782+240><thread=2760 (0xAC8)>
~Select First Certificate: 1  $$<SMS_CLIENT_CONFIG_MANAGER><04-30-2014 12:08:37.783+240><thread=2760 (0xAC8)>
~Certificate Issuers:   $$<SMS_CLIENT_CONFIG_MANAGER><04-30-2014 12:08:37.783+240><thread=2760 (0xAC8)>
Checking configuration information for server: WINSCCM.TEST.LOCAL.~  $$<SMS_CLIENT_CONFIG_MANAGER><04-30-2014 12:08:37.785+240><thread=2760 (0xAC8)>
~No Fallback Status Point installed on the Site  $$<SMS_CLIENT_CONFIG_MANAGER><04-30-2014 12:08:37.785+240><thread=2760 (0xAC8)>
~Install on DC: False  $$<SMS_CLIENT_CONFIG_MANAGER><04-30-2014 12:08:37.786+240><thread=2760 (0xAC8)>
Sleeping for 322 seconds...  $$<SMS_CLIENT_CONFIG_MANAGER><04-30-2014 12:08:37.814+240><thread=2760 (0xAC8)>
Thread has been inactive too long. Closing thread~  $$<SMS_CLIENT_CONFIG_MANAGER><04-30-2014 12:10:22.894+240><thread=4636 (0x121C)>
--- This thread is terminating due to inactivity  $$<SMS_CLIENT_CONFIG_MANAGER><04-30-2014 12:10:22.895+240><thread=4636 (0x121C)>
----- Terminated CCR processing thread. There are now 0 processing threads  $$<SMS_CLIENT_CONFIG_MANAGER><04-30-2014 12:10:22.895+240><thread=4636 (0x121C)>
0
 
nutekconsultantAuthor Commented:
fixed the issue - I created a new lab env't with WIndows 2012 R2 and SQL 2012 R2...installed SCCM 2012 sp1 rtm.... created a new Win2008 r2 test server and new windo7 pro test PC...joined to domain es all....and right away the clients installed.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

  • 4
  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now