Anywhere Access broken

I have a Windows 2012 Essentials server on which Anywhere Access was setup and working for about a month and then quit working.  I had initially purchased and installed a certificate from my DNS hosting company.  When things quit working, I attempted a number of things to no avail.  So I decided to try re-running the Domain Name setup under Anywhere Access and using Microsoft's remotewebaccess.com personalized domain - I was able to designate a name and then ran the repair per the instructions - this completes with no errors.  The issue is when I try to access the web site https://mydomain.remotewebaccess.com - I get a Certificate Error... "There is a problem with this website’s security certificate." and the only option is "Click here to close this webpage. "  I am guessing that somehow RWA is still associated with the certificate I purchase and installed previously.  Can someone please help me figure out how to fix this?  Thank you in advance.
Capture.JPG
Duncan007Asked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
Jeffrey Kane - TechSoEasyConnect With a Mentor Principal ConsultantCommented:
So, yes, you are correct -- the certificate you bought was probably for remote.yourdomain.com.

In order to use Microsoft's remotewebaccess.com you must also secure a certificate from Microsoft using the server's wizards.

However, this is really unnecessary because that service is designed for folks who don't want to have their own domain name, and you have one.

So, this is what you need to do:

1. Export your current SSL Certificate (just save it in a convenient location)

2.  On the server dashboard, click "Settings" in the upper right corner and then select "Anywhere Access"

3.  Under Domain Name click Set up...  and change this back to what is on your current certificate (probably remote.yourdomain.com).  To do this, you need to release the current domain and then proceed to set up your proper one.  Then select the option to set up the domain manually so you can import the previously exported SSL certificate.

4.  Then, click the Configure... button at the top of the window to go through the full settings wizard

If your router does not support UPNP, you must set up your router manually.  Instructions for most routers are contained in this document:
http://social.technet.microsoft.com/wiki/contents/articles/14153.windows-server-2012-essentials-router-setup.aspx
0
 
Shreedhar EtteCommented:
Please follow below steps to configure proper certificate:
1.Open IIS Manager from Administrative tools.
2.Expand your server name.
3.Expand Sites.
4.Select the Default Web Site and click the Bindings… action.
5.Select HTTPS *:443: and click Edit
6. Choose your trusted certificate and click View to ensure that you have the corresponding private key for that cert.
7.Click Ok twice and then Close.
0
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
FYI, I suggest that you DO NOT FOLLOW THE STEPS OUTLINED ABOVE BY Shreedhar Ette, as this will NOT CONFIGURE A NUMBER OF ADDITIONAL SETTINGS REQUIRED BY ANYWHERE ACCESS (such as DNS, and user permissions).
0
 
Duncan007Author Commented:
Jerrey - I followed all of your steps exactly - everything appears to complete without errors in the console... however I am still having the same problem... I tried opening the website in Firefox and it gave me a little more information which might help... I am pasting the contents of the message below... I substituted <domain_name> for the actual domain name...

-------------

This Connection is Untrusted

You have asked Firefox to connect securely to remote.<domain_name>.com, but we can't confirm that your connection is secure.

Normally, when you try to connect securely, sites will present trusted identification to prove that you are going to the right place. However, this site's identity can't be verified.
What Should I Do?

If you usually connect to this site without problems, this error could mean that someone is trying to impersonate the site, and you shouldn't continue.

remote.<domain_name>.com uses an invalid security certificate. The certificate is not trusted because it is self-signed. The certificate is only valid for Linksys (Error code: sec_error_cert_signature_algorithm_disabled)

---------------

I can tell you that I did purchase and install the certificate from my DNS host, and things were working fine originally for some time.

Please help!  Thank you!
0
 
Duncan007Author Commented:
Ok, I figured it out! - somehow remote management got enabled on the router (older Linksys unit) and it was intercepting HTTPS traffic - I turned it off and RWA is working fine now.  Firefox gave me the clue.

Thank you.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.