Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 296
  • Last Modified:

Exchange Web services - EWS

Hi

I have a Exchange 2010 SP2 Dag environment.

Using exchange microsoft test connectivity tool.

When I set internal url the external test fails, when I set external url internal test fails.

When I set both url's in a single shell command, internal url fail.

Is anyone able to shed any light on this.
0
DeepFat
Asked:
DeepFat
  • 4
1 Solution
 
MAS (MVE)Technical Department HeadCommented:
What is the command used to set the URls?
0
 
DeepFatAuthor Commented:
We have 3 cas servers so I use the following command naming each server

Set-WebServicesVirtualDirectory –Identity ServerName\EWS* -InternalUrl https://mail.domain.co.uk/ews/exchange.asmx

I also found after applying the commands Microsoft test connectivity test show successful on the internal network but unsuccessful on external network and only for around 10 minutes, then my test fails on internal and is successful on external.

I have also tried the following and tests are only successful on the external network.

Set-WebServicesVirtualDirectory –Identity ServerName\EWS* -InternalUrl https://mail.domain.co.uk/ews/exchange.asmx -ExternalUrl https://mail.domain.co.uk/ews/exchange.asmx
0
 
Simon Butler (Sembee)ConsultantCommented:
Ensure that the host name resolves internally correctly to begin with.
You will probably need to use a Split DNS to ensure that works.

What error does the test fail with?

I would also upgrade the server - Exchange 2010 SP2 is no longer supported, you need to be on Exchange 2010 Sp3 to be supported.

Simon.
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
DeepFatAuthor Commented:
Issue was resolved by manually removing EWS settings and then re-applying all autodiscover settings and restarting server.
0
 
DeepFatAuthor Commented:
This solution was not suggested by anyone else on the forum and required further investigation from other forums to resolve.
0
 
DeepFatAuthor Commented:
Set-WebServicesVirtualDirectory –Identity ServerName\EWS* -InternalUrl https://mail.domain.co.uk/ews/exchange.asmx -ExternalUrl https://mail.domain.co.uk/ews/exchange.asmx
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now