?
Solved

Outlook Out Of Office Reply - Error

Posted on 2014-04-29
29
Medium Priority
?
248 Views
Last Modified: 2014-08-16
Hello,
When any user in the company tries to set up an Out of Office Away Message they get the following error. The error message is "Your Automatic reply settings cannot be displayed because the server is currently unavailable". They can set it in OWA however. Not sure what this could be?

They have a Windows 2008 SBS with Exchange 2007.

Can anyone please help point me in the right direction?

Thanks in advance!!
0
Comment
Question by:eshiram
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 14
  • 5
  • 4
  • +4
29 Comments
 
LVL 4

Expert Comment

by:SEHC
ID: 40030304
do you have your activesync published in DNS? because if it is not that can cause the issue.
0
 
LVL 4

Expert Comment

by:SEHC
ID: 40030318
0
 
LVL 12

Expert Comment

by:Md. Mojahid
ID: 40031346
disabled IPv6 on nontunnel interfaces

and also try this one
Did you by chance go down this road...? Ensuring you have the necessary SRV record in your external DNS zone?

http://support.microsoft.com/kb/940881
0
Get 15 Days FREE Full-Featured Trial

Benefit from a mission critical IT monitoring with Monitis Premium or get it FREE for your entry level monitoring needs.
-Over 200,000 users
-More than 300,000 websites monitored
-Used in 197 countries
-Recommended by 98% of users

 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 40033365
Which version of Outlook are you using?  If 2013 there is a known issue with some updates that have caused the Autodiscover service to stop working -- which is what gives this exact error message.

See this article for detailed info:
http://www.infoworld.com/t/microsoft-windows/botched-outlook-2013-patches-kb-2837618-and-kb-2837643-break-out-of-office-reply-freebusy-and-more-232055

Removing those updates should fix the problem for you.
0
 

Author Comment

by:eshiram
ID: 40034163
Md. Mojahid,
I did what you said, I disabled IPv6 on nontunnel interface and now I am having huge issues. It takes 45 minutes to an hour for my server to come up after reboot, My Exchange services won't start, my services.msc, and network connections won't open. There is an X next to my network connection in the system tray. When I try to open it, it freezes.

There is no System Restore, it is Windows 2008 SBS. I tried following the instructions on this link to get it back but no cigar - please help!!! http://blogs.technet.com/b/sbs/archive/2008/10/24/issues-after-disabling-ipv6-on-your-nic-on-sbs-2008.aspx
0
 

Author Comment

by:eshiram
ID: 40034172
Ok, I figured it out. Exchange/server is back to normal. That scared the shit out of me. Was up all night. Anyways, back to square one.

Jeffrey, most people do not use Outlook 2013. But I will look into this as that is what I have been using for testing in this scenario.
0
 

Author Comment

by:eshiram
ID: 40102615
I've requested that this question be deleted for the following reason:

No one has been answering.  I still have the issue. I know issue is with IIS but I cannot figure it out. Resolutions here didn't work.
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 40102616
So, I'm sorry that I missed your last postings.  But I do believe I may have the solution for you.

Check out this article:
http://www.petenetlive.com/KB/Article/0000897.htm

Essentially it points to EITHER having a proxy server configured on the client workstations, OR incorrect Virtual Folder Permissions.
0
 

Author Comment

by:eshiram
ID: 40105940
Hi Jeffrey,
Thanks for your response. I tried the IIS option. I checked the proxy and that is not the issue. The link you sent seems pretty straightforward. I did get stuck somewhere though. Some virtual directories are managed through the EMC and I cannot find where they are in the EMC. The Virtual Directories I had trouble with are "Exchange" and "Exchweb". Both of those have Windows Authentication method disabled and I need to enable them. I just don't know where to do that in the EMC.

Thanks again, I appreciate your help.
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 40109355
Did you do the "Test Email AutoConfiguration" on the workstation?

You definitely need to be sure that AutoDiscover is working internally.
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 40109364
Oh, and to enable Windows Authentication for the Virtual Directories?  That's done in IIS, not EMC.

As the article states:

"Another common problem, is that the EWS virtual directory has misconfigured permissions in IIS."

And then it goes on to show you specifically where to change it in IIS.
0
 

Author Comment

by:eshiram
ID: 40122055
Hi Jeffrey,

1. Yes, I did the Test AutoConfiguration and it failed.
2. The only virtual directories I am having issues with are "Exchange" and "Exchweb". When I try to enable Windows Authentication for both of them I get an error message, which I attached here.

Thanks for your help.
iiserror.JPG
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 40124473
This has nothing at all to do with the Exchange and Exchweb virtual directories.  You shouldn't even be touching those.

The issue is caused by problems with the EWS virtual directory.

Furthermore, the Exchange and Exchweb directories are irrelevant to your environment.  They are only there to assist with migrations from Exchange 2003, as 2007 and later uses the OWA directory instead.

Settings for THAT directory (OWA) should not be made in IIS, but rather in the Exchange Management Console >  Server Config > Client Access > Outlook Web Access > OWA (SBS Web Applications) > properties

The fact that your AutoConfiguration Test failed is the root of the problem.  It has to do with DNS, so don't monkey with any of the permissions settings -- that's not going to help you.

You should essentially be able to access the following URL from INSIDE your network:
https://remote.yourdomain.com/ews/exchange.asmx

(unless you specified something other than the default "remote" when you set up your domain name)

If you cannot resolve this URL internally then you need to run the following wizards in your SBS Console > Network > Connectivity Tab:

Set up your Internet Address Wizard
and then run the
Fix My Network wizard

These will resolve most all of your issues by rewriting the appropriate entries to DNS.
0
 

Author Comment

by:eshiram
ID: 40128645
Jeffrey,
I was able to access https://remote.yourdomain.com/ews/exchange.asmx from within my network, it redirects me to a services.wsdl page full of xml. This server is also a DNS server. It has DNS forwarders to OpenDNS IPs. Everything else looks normal. Still having the issue with Out of Office opening on Outlook client.

Thanks
0
 

Author Comment

by:eshiram
ID: 40138243
I ran the Microsoft Analyzer tool which had a bunch of errors. I attached it here, I don't fully understand it to use it as direction for what to do next. Can you "decipher" it?

Thanks!!
0
 
LVL 38

Expert Comment

by:Hypercat (Deb)
ID: 40152337
I see that no one has responded for quite a few days.  There is no file attached to your last post, so nothing to analyze.  If you want someone to look at it, please post the file.

Just as an offhand comment, I would advise removing the DNS forwarders and use the root hints only.  If this problem is DNS-related, this should resolve any issues in that regard.  Also, as advised by Jeffrey Kane, you should rerun the wizards to make sure that the SBS settings for your domain are applied correctly.
0
 
LVL 19

Expert Comment

by:Adam Farage
ID: 40152866
Please upload the file.

Furthermore, NEVER disable IPv6 unless there a specific Microsoft based KB that shows to disable it (and you disable it through the registry). You will most likely break a lot of things by unchecking the IPv6 checkbox... mainly the TCP/IP stack.
0
 

Author Comment

by:eshiram
ID: 40153047
Hypercat/Adam,
Thanks for your response. I actually thought I uploaded it. It is attached now.

-eshiram
exchangeconnectivitytest.pdf
0
 
LVL 38

Expert Comment

by:Hypercat (Deb)
ID: 40153077
This test was done externally right?  Is this the normal situation when users are having a problem contacting your server, or are they having problems internally as well?

There are some autodiscover errors as well as a problem with your SSL certificate.  First thing I'd check is to see if your SSL certificate is missing or invalid.  Is the server using a self-signed or public certificate?

As for the autodiscover errors, the error message states that the domain is non-existent. Since you were doing this test as a remote test, then it appears that your public DNS zone doesn't have an autodiscover record for your domain.
0
 

Author Comment

by:eshiram
ID: 40153336
yes it was done externally. problems happen internally and externally.

my public dns zone has an srv record for autodiscover. when i go to owa outside it does not give me an SSL error. SSL is through GoDaddy.
0
 
LVL 19

Expert Comment

by:Adam Farage
ID: 40153349
Run the following:

Get-ExchangeCertificate | FL

Let us know the output, I dont think something is right here.
0
 

Author Comment

by:eshiram
ID: 40154618
Ok, I ran the command and attached it here. I replaced my primary domain, secondary domain, hostname, and company name with domain, secondarydomain, hostname, and Full Company Name - respectively. I know that information is usually concealed in these forums so I am just following suit.

Thanks for helping,
Cert.txt
0
 
LVL 38

Expert Comment

by:Hypercat (Deb)
ID: 40154770
First thing - you have many certificates that are assigned to the various Exchange services that are invalid/expired.  I can see that your GoDaddy certificate is correctly assigned to all Exchange services (IMAP, POP, SMTP and IIS).  I would remove any other certificates that are expired, and also remove the self-signed certificate (thumbprint 6A685515F3281FFA0EE72CCCFA35A1ABAD4CD16F) that is assigned to the POP and SMTP services. That one is valid, and you don't want to delete it completely, but just un-assign to from the Exchange services.
0
 

Author Comment

by:eshiram
ID: 40160062
Hypercat,
I can delete the expired ones and disable the self-signed? Is the following command the right way to unassign the cert?

Remove-ExchangeCertificate -Thumbprint 6A685515F3281FFA0EE72CCCFA35A1ABAD4CD16F

Thanks!!
0
 
LVL 38

Expert Comment

by:Hypercat (Deb)
ID: 40160133
No - you want to use Enable-ExchangeCertificate:

Enable-ExchangeCertificate -Server Servername -Services ""  -Thumbprint [your thumbprint]

I think this will work to leave the certificate in place but remove any assigned services. If it doesn't work (I haven't tested it), then you can use the Remove-ExchangeCertificate, which will actually delete the certificate but that shouldn't cause any problems.
0
 

Author Comment

by:eshiram
ID: 40180667
Hypercast,
I tried enable first but it didn't work. It said this certificate doesn't apply to Exchange - even though I was removing services. I did remove also but it messed things up so I readded it.
0
 
LVL 11

Expert Comment

by:hecgomrec
ID: 40181087
I have only seen this error if the user is in an older database than the main server.

Let's say if your user is in a 2010 mailbox server and your CAS server is a 2013.

Moving the mailbox to the latest server should do the trick.

Also, someone reported once that outlook 2003 will have issues if not fully updated and 2007 too.
0
 

Accepted Solution

by:
eshiram earned 0 total points
ID: 40239843
I had a friend help me with this. I am not sure what he did exactly. I know he did some troubleshooting with SBS console wizards that helped lead him to his solution.
0
 

Author Closing Comment

by:eshiram
ID: 40264833
I had a friend help me with this. I am not sure what he did exactly. I know he did some troubleshooting with SBS console wizards that helped lead him to his solution.
0

Featured Post

Does Powershell have you tied up in knots?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article describes how to import an Outlook PST file to Office 365 using a third party product to avoid Microsoft's Azure command line tool, saving you time.
This article will help to fix the below errors for MS Exchange Server 2013 I. Certificate error "name on the security certificate is invalid or does not match the name of the site" II. Out of Office not working III. Make Internal URLs and Externa…
The video tutorial explains the basics of the Exchange server Database Availability groups. The components of this video include: 1. Automatic Failover 2. Failover Clustering 3. Active Manager
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…
Suggested Courses
Course of the Month15 days, 15 hours left to enroll

741 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question