Solved

Avoid "to protect your security IE has restricted this webpage" when launching local html

Posted on 2014-04-29
3
630 Views
Last Modified: 2014-04-30
I am building a flash file to run in a continuous loop on a unmanned computer.

The flash file is embedded in a single HTML page that is located in the root of the local machine.

I keep getting the "to protect your security IE has restricted this webpage from running scripts or ActiveX controls that could access your computer." challenge on startup.

My understanding is that I can add a "Mark of the Web" to the HTML declaration, or change the security settings on the machine.

Since this machine is a single use machine in a locked cabinet with no keyboard or mouse, it is possible for me to change the security settings. However, it still has internet access for polling and content updates and is in a high visibility public facility so I'm always skittish about lowering my security settings.

What is the experts advice on how to launch a local HTML page using an automated script without the warning message?
0
Comment
Question by:David Brugge
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
3 Comments
 
LVL 83

Expert Comment

by:Dave Baldwin
ID: 40031003
In Internet Options in the control panel under Advanced, I checked "Allow Active content to run from files" and it stopped showing that message for my javascript pages.  Maybe that will allow your Flash to run also.
0
 
LVL 26

Accepted Solution

by:
David Brugge earned 0 total points
ID: 40033838
Thanks for the suggestion Dave, but I really wanted to avoid changing my security settings.

I went to the Microsoft site: http://msdn.microsoft.com/en-us/library/ms537628(v=vs.85).aspx

This explained why the warning was displayed and what triggers it.

Then it went on to explain workaround solutions for developers testing websites on their own machines.

I added the line  <!-- saved from url=(0014)about:internet --> just below the .doc statement above the header, and that did the trick.
BTW, instead of about:internet, you can add any url that you want. The number in parenthesis is the number of characters including spaces, of the line itself.
0
 
LVL 83

Expert Comment

by:Dave Baldwin
ID: 40033848
Good to know.  I had never heard of that before.
0

Featured Post

[Webinar] Learn How Hackers Steal Your Credentials

Do You Know How Hackers Steal Your Credentials? Join us and Skyport Systems to learn how hackers steal your credentials and why Active Directory must be secure to stop them. Thursday, July 13, 2017 10:00 A.M. PDT

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Today, still in the boom of Apple, PC's and products, nearly 50% of the computer users use Windows as graphical operating systems. If you are among those users who love windows, but are grappling to keep the system's hard drive optimized, then you s…
Ever visit a website where you spotted a really cool looking Font, yet couldn't figure out which font family it belonged to, or how to get a copy of it for your own use? This article explains the process of doing exactly that, as well as showing how…
This Micro Tutorial will demonstrate how nuggets on the Web are formatted by using Chrome Developer Tools. These tools would not only view the site's CSS but it can also modify it and save the CSS to use on your own site.
How to create a custom search shortcut to site-search Experts Exchange using Google in the Firefox browser. This eliminates the need to type out site:experts-exchange.com whenever you want to search the site. Launch your Bookmark Menu: Press 'Ctrl +…

617 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question