• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 16461
  • Last Modified:

Change Autodiscover settings in PowerShell

Hi,

We support a company that changed it's name a while back and we changed all the settings, domains, URL's etc. All is OK apart from the Autodiscover settings in Exchange 2010.

This isn't really a big problem as all the users apart from the Director are on PC's, but his Mac will constantly change the server address to the old address and he wants it changing.

The issue is, when I have tried to change the Internal and External Autodiscover address in PowerShell. The Internal command I used does nothing and the External command throws back an error.

The commands I've tried are:

Internal: Set-ClientAccessServer –Identity * –AutodiscoverServiceInternalUri “https://autodiscover.domain.co.uk/autodiscover/autodiscover.xml”
(This doesn't error but doesn't actually change the internal address)

External: Set-ClientAccessServer –Identity * –AutodiscoverServiceExternalUri “https://autodiscover.domain.co.uk/autodiscover/autodiscover.xml”
(This gives me the error below)

A positional parameter cannot be found that accepts argument '-AutodiscoverServiceExternalUri'.
    + CategoryInfo          : InvalidArgument: (:) [Set-ClientAccessServer], ParameterBindingException
    + FullyQualifiedErrorId : PositionalParameterNotFound,Set-ClientAccessServer


When I do a Get-AutodiscoverVirtualDirectory | List it show both internal and external address's to still be the old address.

I have also tried with the server address where the * is, but same results.

Any help would be appreciated.

Regards,

James
1
YorkData
Asked:
YorkData
  • 2
1 Solution
 
YorkDataAuthor Commented:
Also if I do Get-ClientAccessServer | fl AutoDiscoverServiceInternalUri and ExternalUri The client internal address is correct but the External is blank?

I understand now that I've been changing the client access not the virtual directory, but I'm still unsure why I get the error when trying to change the external address, and how I change the internal and external virtual directory address's?

Thanks
0
 
ronnypotCommented:
Hi,

If you do a  Get-ClientAccessServer | fl you will get all options for the clientaccessserver cmdlet and you will notice there is no ExternalUri option over here.

The internalurl and externalurl option for the AutodiscoverVirtualDirectory can be set by using the following commands:
For internal: Set-AutodiscoverVirtualDirectory -Identity * –internalurl “https://yourdomainname/autodiscover/autodiscover.xml”

For external: Set-AutodiscoverVirtualDirectory -Identity * –externalurl “https://yourdomainname/autodiscover/autodiscover.xml”

Also don't forget there are serveral other option where to specify a internalurl and externalurl, see this page for all the options: http://exchange.sembee.info/2010/install/clientaccesshostnames.asp
0
 
YorkDataAuthor Commented:
Thanks for your help. Thought I had tried that command but clearly I hadn't as that worked!

Thanks for the guide. I had done everything in it already. Was just at the last hurdle.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now