Avatar of Scott Thompson
Scott Thompson
Flag for United States of America asked on

Windows 7 Permissions Issue

Hello!

I've got a fun one today!

I have a computer that came in having internet issues.  It will not get an IP address.  After diving into it, I have determined that it's an issue with the drivers and Device Manager.  I have tried to uninstall/reinstall the drivers, but it won't let me.  When I choose to manually update the driver, I get an Access Is Denied error.

So, I tried to manually set the IP address for the Local Area Connection.  I go into the properties and highlight IPV4, but I can't click on Properties!

I'm stuck!

I have already ran the Avast Removal Tool (because she had Avast Internet Security installed and downgraded to the Free Antivirus) to remove any remnants of Avast that may be causing issues.

I have ran sfc /scannow, which finds no errors.

I have ran the System Update Readiness Tool, which fails with no error code (says not installed).

I have done an in-place upgrade, which went through fine, but I'm still having the same issues!

Any suggestions?

(P.S, I have ran sfc /scannow, SURT, and Avast Removal Tool since the in-place upgrade also)
Windows 7Internet Protocols

Avatar of undefined
Last Comment
nobus

8/22/2022 - Mon
jcimarron

Scott Thompson

ASKER
I'll take a look at that.  Here's something weird.  I went to Safe Mode with Networking and I was able to change the TCPIP properties!  I'm rebooting now to see if it sticks.
Scott Thompson

ASKER
Nope, when you go to normal mode, it does not work.  And when I go back to safe mode, the default gateway has now been erased, but the other numbers are there.

In safe mode, I tried pinging, but I get back General Failure.

I have also tried to install Avast! Free Antivirus, but it stops with error 0x0000005! in the self-defense module.
Your help has saved me hundreds of hours of internet surfing.
fblack61
epichero22

Can you log on to the local administrators account?

Go to the command prompt with elevated privileges and type in:

 net user administrator /active:yes

The log off your account and log onto the administrator account and update the drivers from there.
Scott Thompson

ASKER
I have activated the administrator account and tried to update drivers in normal mode, no luck.  Safe mode, it works.  But, it breaks when you go back to normal mode, plus the internet in safe mode still doesn't work.

Also, tried to install Avast! Free Antivirus in normal and safe mode with Administrator account.  No luck.  Still stopped.  Currently installing AVG Free 2014 64 bit in normal mode to see if that goes through.  Been running for 20 minutes and only halfway through.
Scott Thompson

ASKER
Here's the error message I just got on installing AVG.

AVG Fail
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
ASKER CERTIFIED SOLUTION
nobus

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
Scott Thompson

ASKER
I know, but I always avoid it if I can. :)  Kind of stubborn that way.  The main thing is it's for a business and she has everything set up on here.  She is a particular person so everything has to be a certain way.  She already bought a new computer to replace this while we try to repair it.

Here's a log from scanning with AVG in safe mode.  Got it to install in safe mode.
avgrep.txt
nobus

>>  She is a particular person so everything has to be a certain way.    <<   most people feel like this; but the job of the "repairman" incluces good advice also !!
Scott Thompson

ASKER
Looks like we are going to have to reload.  I have contacted the customer and I'm waiting on a response on what to backup.  If you have any other suggestions, I'm up for it.  I did get the network to have an IP address after giving proper permissions to it in the registry, but I still got a General Failure when pinging.  However, restarting the computer seems to undo everything I did...
Experts Exchange is like having an extremely knowledgeable team sitting and waiting for your call. Couldn't do my job half as well as I do without it!
James Murphy
nobus

does it have a recovery partition?  that's the fastest way then - after a backup of course
if not sure -post the PC model
Scott Thompson

ASKER
Reloaded the system from recovery and backed up data.  I hope that I get everything put back on that they need.  Thanks for your help!
nobus

it's often the fastes t way to a clean OS
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.