Link to home
Start Free TrialLog in
Avatar of Yann Shukor
Yann ShukorFlag for France

asked on

"unable to assign Admistrator as owner"

Hi

On a Windows 200 server I have some files that aren't getting saved during my backup

I checked the files and administrator doesn't have access to them

TakeOwn /F *.* /A /D Y

Open in new window

this returns:
unable to assign Admistrator as owner

CScript xcacls.vbs *.* /G Administrateur:F /I Enable /F 

Open in new window

this returns:
Error -2147217406:  occurred setting Win32_LogicalFileSecuritySetting object. (Msg#501)
Error description: Not found

any ideas ?
yann
Avatar of Scobber
Scobber
Flag of Australia image

Are you spelling administrator correctly?
What server OS is it? 2000 2003 2007
im assuming 2000

im some circumstances you need to reference a user by computername\username
are you logged in as 'computername\administrator'

if you are run
takeown /f "c:\path\to\folder" /R /A
cacls "c:\path\to\folder" /g computername\administrator:F /C /T
cacls "c:\path\to\folder"

make sure you have no deny entries
Avatar of Yann Shukor

ASKER

Yes, sorry, Windows 2000

administrateur, yes it is a french server

Tried suggested commands:
takeown ; same error as before
cacls:
No mapping between account names and security IDs was done.
was this a domain member or a domain controller?

sounds to me that the domain it is / was a member of cannot be found.

in any case you may need to check the AD hierarchy for the server, setting dns correctly,
 unjoin the domain or use dcpromo to kill the domain so you can make the computer operate standalone.

all else fails pull the drives and takeown on another system
ASKER CERTIFIED SOLUTION
Avatar of Yann Shukor
Yann Shukor
Flag of France image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
situation is fixed