We help IT Professionals succeed at work.

Mailbox Issue & Outlook 2010/13 Rules

467 Views
Last Modified: 2014-06-28
Recently I changed the server SPAM filter settings to label spam and place it directly into (employee mailbox) junk-email folder.

I used to have local .pst folders as default and used Outlook rules to move SPAM for me. Now, I have set employee mailboxes as default using active sync. with Exchange 2010.

So far for one of my employees the SPAM (labeled) stays in the Inbox.
For some reason the Outlook rules do not work either to move them to junk-email.

I tested this with both Outlook 2010 and 2013, still the same issue.
Also, recreated local profiles with cached mode disabled, no go.
Is something wrong with this individual mailbox? What can I do at this point?

Thanks.
Comment
Watch Question

CERTIFIED EXPERT
Most Valuable Expert 2014

Commented:
I would be looking at the rules on the mailbox to begin with.
How are you placing the messages in the junk email folder? The usual reason if you can tag the messages is to use a transport rule to set the SCL value to 8 (or whatever you have the antispam settings set to move in to the junk email folder).

Simon.
SimonIT Manager

Author

Commented:
I currently have the GFI filter set to move tagged spam directly into junk-email.
It works fine for me and other employees, no rules required.
I deleted my Outlook rule after I made changes to anti-spam settings.

However, this one mailbox is not responding to any rules or the recent changes.
I want to avoid to recreate this individual mailbox, instead looking for a different solution.

Maybe something in exchange console that would refresh it and make it work.
SimonIT Manager

Author

Commented:
I contacted gfi support and asked about the communication between gfi filter and this specific mailbox.
The filter is not placing spam into junk-email folder for that user.

MailEssentials tag the email and put an SCL value on it. The SCL value is read by Exchange and Outlook and processed accordingly.
If it is just one user, that means Outlook is not reading it properly. If it was Exchange it would affect everyone.
Exactly why Outlook is not reading the SCL value I don't know. As long as the just Email filtering is enabled, it should be able to do so.
CERTIFIED EXPERT
Most Valuable Expert 2014

Commented:
Can you see the SCL value in the headers of the message?

Simon.
SimonIT Manager

Author

Commented:
Yes, the GFI filter puts the value of 1 for SPAM to be moved to junk-email.
Exchange server puts the SCL value of 9.

Also, I have two email addresses assigned to this specific mailbox. Employee & HR.
Not sure if this would contribute to my issues.

Thanks.
SimonIT Manager

Author

Commented:
I found this online which might help ... however, is it possible that I could break something else?
I didn't run these commands, need to install the power-shell and restart my server.
Also, what exactly would I be doing here?

Get fully connected through PowerShell, then execute the following command:
Get-TransportConfig |fl JournalingReportNdrTo
After running above command examine if the affected mailbox where the rules are not working is listed in output of above command.
If yes, then  this is by-design.

To resolve: please perform below steps.
1. Run: Set-TransportConfig –JournalingReportNdrTo “<>”
2. Run: Get-TransportConfig | fl JournalingReportNdrTo*
3. Verify that is JournalingReportNdrTo is empty
CERTIFIED EXPERT
Most Valuable Expert 2014

Commented:
I am curious why you think that command would resolve the issue.
I have found a reference to the command that you have posted, but in relation to an issue with journaling to a mailbox that has rules (as you should use a dedicated mailbox for journaling).

Are you using journaling? If not then that command is completely irrelevant.

Simon.
SimonIT Manager

Author

Commented:
I am not using journaling.
I found this in another "solved topic" on experts exchange.
This person had issues with the mailbox rules not working.

https://www.experts-exchange.com/Software/Office_Productivity/Groupware/Outlook/Q_28058758.html
CERTIFIED EXPERT
Most Valuable Expert 2014

Commented:
How odd. That question doesn't really explain where it has come from either, which would tend to suggest that it might have been something else. It would do no harm to run those commands, but I  would be very surprised if they did anything.

Simon.
SimonIT Manager

Author

Commented:
I finally got a chance to look into this issue again and ran the "Get-TransportConfig |fl JournalingReportNdrTo".
No mailbox was listed. Like you said, the command did nothing.
David Johnson, CDSimple Geek from the '70s
CERTIFIED EXPERT
Distinguished Expert 2019

Commented:
small question, why are you using active sync with o utlook and not using an exchange connection?
IT Manager
Commented:
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION
SimonIT Manager

Author

Commented:
The final solution was not provided by any Experts.
Unlock the solution to this question.
Join our community and discover your potential

Experts Exchange is the only place where you can interact directly with leading experts in the technology field. Become a member today and access the collective knowledge of thousands of technology experts.

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.