Link to home
Start Free TrialLog in
Avatar of Littlet5621
Littlet5621

asked on

Exchange setting problem

We have a exchange 2010 server and it is having a spoofing issue.  After some searching i have come up with what looks like a good solution but which is running the following command to remove the option for anonymous connections.

Get-ReceiveConnector “My Internet Receive Connector” | Get-ADPermission -user “NT AUTHORITY\Anonymous Logon” | where {$_.ExtendedRights -like “ms-exch-smtp-accept-autho<wbr ></wbr>ritative-d<wbr ></wbr>omain-send<wbr ></wbr>er”} | Remove-ADPermission 

Open in new window


problem is when i try to run it i receive this error

The operation couldn't be performed because object 'rgb-exchange1.batterysource.com\My Internet ReceiveConnector' could
n't be found on 'rgb-exchange1.batterysource.com'.
    + CategoryInfo          : NotSpecified: (:) [Get-ReceiveConnector], ManagementObjectNotFoundException
    + FullyQualifiedErrorId : 1C8D7C1,Microsoft.Exchange.Management.SystemConfigurationTasks.GetReceiveConnector

Open in new window


Any suggestions on where my problem may be.
Avatar of Justin Yeung
Justin Yeung
Flag of United States of America image

do a get-receiveconnector on your exchange shell console.

the identity of the connector should be like "servername\the name of the connector"

The error indicated the identity of the connector can't be found which the name doesn't match.

it doesn't accept wildcard on the parameter of identity however it can be using pipeline value
ASKER CERTIFIED SOLUTION
Avatar of Kotteeswaran Rajendran
Kotteeswaran Rajendran
Flag of Malaysia image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial