Link to home
Start Free TrialLog in
Avatar of infedonetwork
infedonetwork

asked on

Autodiscovery on exchange 2013 error 10

Hi
I build a new exchange 2013 server and I install a godaddy certificate.
I run the following on exchange:

Set-ClientAccessServer -Identity exchange -AutodiscoverServiceInternalUri https://mail.XXX.com/autodiscover/autodiscover.xml

Set-WebServicesVirtualDirectory -Identity "exchange\EWS (Default Web Site)" -InternalUrl https://mail.XXX.com/ews/exchange.asmx

Set-OABVirtualDirectory -Identity "exchange\oab (Default Web Site)" -InternalUrl https://mail.XXX.com/oab

Set-OutlookProvider -Identity EXPR -CertPrincipalName msstd:mail.XXX.com

I'm still getting the error message bellow.
If I go to Outlook proxy settings it has exchange.XXX.local and not the mail.XXX.local

Strange is that few PC get the proper settings but most does not.
Any idea why?
User generated image
Avatar of Gareth Gudger
Gareth Gudger
Flag of United States of America image

Looks like you are setting up split-brain DNS. Did you configure these A records on your local DNS servers?
Avatar of infedonetwork
infedonetwork

ASKER

Yes I did.
I don't think the problem is on the server.
Everything there point to the external url.
Only 2 out of 10 computers has this problem were the exchange proxy resolve to the internal design even if I set it manually to the external one.
One thing I did on those two was that I click on install certificate when I first get the error before I even install the godady certificate on the server.
I try clear ssl on Ie but didn't work.
Hmm. Try this.

Set-OutlookAnywhere -ExternalHostName mail.xxx.com -ExternalClientAuthenticationMethod Basic -ExternalClientsRequireSSL $true -InternalHostName mail.xxx.com -InternalClientAuthenticationMethod NTLM -InternalClientsRequireSSL $true

Open in new window

ASKER CERTIFIED SOLUTION
Avatar of infedonetwork
infedonetwork

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
The problem was not related to the new exchange server