We help IT Professionals succeed at work.

Ipads and wireless ?

252 Views
Last Modified: 2014-07-28
Hello all,
 
We have an odd wireless issue at one of our sites. We using Cisco AP’s and NPS to authenticate the users. We have user who can connect and others that do not. They are all in the same building and this happens on different AP’s. When we look at the logs on the NPS server we are seeing the user authenticating but the DHCP is not assigning them an IP. If you use a laptop it works fine though.

Has anyone ever seen this?
Comment
Watch Question

IT Director
Commented:
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION

Author

Commented:
We have a ton of ips we are safe there. Which device would you clear the arp on ? Thanks for your help !
David KonigIT Director

Commented:
I guess all AP's are controlled with one switch as Vlan's so try clearing the main switch i am not sure.

I am using myself a dozen Cisco AP's in a warehouse but I may have a different setup.

Do all AP’s have the same firmware?
some oneNetwork Architect
CERTIFIED EXPERT
Top Expert 2014

Commented:
Can you post a NPS log for a successful connection and one for an unsuccessful connection (even if they are successful authentications)?

Author

Commented:
It seems it is a DHCP thing . We setup a local dhcp server on the router at the site instead of it coming back to the main dhcp servers our main site and it is working fine now. However what is odd this issue only was an issue with the ipads .. Laptops and android devices worked fine. Setting up this DHCP is not really a solution as it is more of a bandaid until we figure out what is going on.
David KonigIT Director

Commented:
I had an issue this weekend where I have changed a WIFI password on a wireless modem and after that I couldn’t connect to the modem wirelessly, the fix was on the laptops i had to go into view wireless connections and delete the existing SSID and then reconfigure and it worked.

If you made any security changes to the wireless on the modem you may have to do the same delete the existing connections on anything that has already been hooked up to the modem before, because windows or the iPad will have saved the previous settings and now the security does not match since it was changed and it does not overwrite.
some oneNetwork Architect
CERTIFIED EXPERT
Top Expert 2014

Commented:
@D.Konig - this is for WPA-Enterprise, not for WPA-PSK.  There are no passwords on the modem/router/AP in this scenario.

Author

Commented:
THanks for the help once we cleared the arp table it would then work.
Unlock the solution to this question.
Join our community and discover your potential

Experts Exchange is the only place where you can interact directly with leading experts in the technology field. Become a member today and access the collective knowledge of thousands of technology experts.

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.