Avatar of mhcbbcadmin
mhcbbcadmin
 asked on

Set up could not parse or process the unnattend answer file for pass [specialize]

I created an install image for a HP EliteBook 840 g1 with Windows 7 pro 64bit.  I uploaded it to our WDS server (Windows Server 2008 R2) and created an unattended installation file.  When I attempted to deploy this image the client computers displayed the following error:

Windows could not parse or process the unattend answer file for pass [specialize].  The settings specified in the answer file cannot be applied.  The error was detected while processing settings for component [Microsoft-Windows-Shell-Setup].

I didn't have time to investigate the answer file, so I "detached" it from the install image and attempted to push the image again but received the same error (despite the answer file being disabled for this image).  The problem is this:  Client laptops that were part of the first round of installs with the answer file attached continue to receive this error.  All "fresh" laptops have been installing and booting up with no problem.  How can previous failed installation attempts continue to cause this issue?  

So far I have tried: Recreating and uploading the install image,  formatting the client hard drives,  DBAN (Darick's Boot and Nuke) to clear the MBR.
Microsoft Legacy OSIT AdministrationWindows Server 2008Microsoft Server OSMicrosoft 365 Enterprise

Avatar of undefined
Last Comment
mhcbbcadmin

8/22/2022 - Mon
TobiasHolm

In unattend.xml:
Search for <ProductKey></ProductKey> in the [specialize] section and remove it.

Look here: http://xpro.se/?s=Specialize
mhcbbcadmin

ASKER
Thanks for the idea, but I am not using an answer file.
Lee W, MVP

What media did you use to create the install image?  Can you post copies of (attach, don't cut and paste long logs please) the following logs, if they exist:

Windows\Panther\Setupact.log
Windows\Panther\UnattendGC\Setupact.log
Windows\System32\Sysprep\Panther\setuperr.log
your answer file.
Experts Exchange is like having an extremely knowledgeable team sitting and waiting for your call. Couldn't do my job half as well as I do without it!
James Murphy
mhcbbcadmin

ASKER
I used the recovery media provided with the laptops.  Unfortunately I can't get any logs off of the failed client computers.  Would logs from a client of the same model that was imaged successfully be useful?
Lee W, MVP

Not likely without a failure to compare them to.
mhcbbcadmin

ASKER
I was able to access some logs, they are attached. I do not have the install image pointing to an answer file.
setupact.log
setupact.log
setuperr.log
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
ASKER CERTIFIED SOLUTION
TobiasHolm

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
Lee W, MVP

mhcbbcadmin

ASKER
I reflashed the bios then ran the diskpart commands while booted into a PXE environment and was successful.  Thanks for the posts!