Link to home
Start Free TrialLog in
Avatar of Impressionist
ImpressionistFlag for Australia

asked on

Remote session disconnected - can connect using RD client for iOS, but not using Remote Desktop on Win7

I am trying to remote into a win server 2008 that I have on my business network. We don't run a terminal services license server, as I only need to connect once in a while as admin to fix a problem.

I can connect without any problems with RD client on my ipad, but I cannot connect from my win7 machine.

I have tried running remote desktop as admin, I've taken the advice of another post here and deleted the MSlicensing key. I've tried putting in the /admin and /console switch in the shortcut. Nothing so far has worked. I still get the error he remote session was disconnected because there are no Terminal Server license servers available to provide a license.

I don't know why iOS RD client works and not win7 RD.
Avatar of Lionel MM
Lionel MM
Flag of United States of America image

On the server do you have it set to receive any version of RDP or network layer security (see picture)? And what is the setting on your Win7 PC (both found in control panel, system, and remote tab). Whatever you have them set to--change them to be the same and also try the less secure option--make sure they are both the same.
RDP-Security.jpg
ASKER CERTIFIED SOLUTION
Avatar of kevinhsieh
kevinhsieh
Flag of United States of America image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
No need to run the command as an Administrator just make sure the "/admin setting is correctly part of the name of the machine you are trying to connect:

C:\WINDOWS\system32\mstsc.exe /v:MDC /admin
Avatar of Impressionist

ASKER

Thanks for the comments. I haven't been back into that office yet to check it out, but I'm thinking the version of remote desktop is the issue
Sorry for the delay in getting back to you on this one, it took me a while to get into that office. Terminal services role was installed, so I got rid of it and all is good. Thanks :)