Link to home
Start Free TrialLog in
Avatar of r-dechristie
r-dechristie

asked on

PASV - 425 IIS7 FTP 7.5 issue

So here is my thing. Nothing has changed in my environment.  Nothing.  All of the sudden 3 ports in my Passive range have stopped working.  I use 50000-50300.  So when the connection uses all of the ports and flips back around to the beginning few, it fails with a PASV - 425 error in the FTP log.  This only happens with ports 50000-50002.  So approx 30 of the 1500 files fail.  Talk about needle in a haystack.  Anyone come across this in the past?  I know its rather vague, but its crazy.  I've run wiresharks, continuous netstat -anp tcp commands and pretty much anything else i could think of.  I actually think i've been looking at it too long.  Any help would be GREATLY appreciated!!!!
Avatar of kevinhsieh
kevinhsieh
Flag of United States of America image

Run netstat -a -b and see if anythung else is using those ports. Another service may have grabbed them.
Avatar of r-dechristie
r-dechristie

ASKER

Yes, i forgot about -b.  It is windows services.  (svhost, wininit, etc...).  I can't change them can I?
Those services are pulling from the range that i want for passive FTP.  I need to move them somehow.  This program should bounce to the next available port, but instead it is erroring out and failing, and the people sending me the files aren't really willing to make any changes on their end since its not their headache.
SOLUTION
Avatar of kevinhsieh
kevinhsieh
Flag of United States of America image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
I found some other ports that are failing:

50000 - wininit.exe
50001 - eventlog
50002 - schedule
50238 - services
50240 - policy agent
50255 - lsass

Here is another question.  Am i causing this since i used netsh command to set the same ports as i set in IIS for FTP?  Couldn't I just expand the dynamic port range and leave the FTP passive ports the same in IIS?
ASKER CERTIFIED SOLUTION
Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
I laid all of the steps that fixed the problem for myself.