Avatar of Roger Cooper
Roger Cooper
Flag for New Zealand asked on

Windows 7 client lost SBS 2003 domain

Hi,
I have a Windows 7 desktop client on an SBS 2003 network. It was working well until I did a dumb thing. We were having a physical restructure so I temporarily put a wireless switch in place for the staff in that area (they are all on laptops) until the network wiring is back in place. It's just a cheap TP Link unit. Here's the stupid part. I plugged the switch into my PC to set it up. Physically I plugged the internet port on the switch into our network, and plugged my PC into one of the ports. I was in a hurry so I ran the software that shipped with the switch rather than use a web interface. The switch setup was fine and is now working.
Now my PC takes a very long time to logon (20 minutes). It cannot load my user profile. I can only periodically connect to network drives. Outlook doesn't reliably connect to exchange. I figured I'd lost the trust of the domain so I disjoined my pc, renamed it and rejoined it to the domain and still the problem persists. I can get to files if I setup a fixed IP but outlook doesn't like the fixed IP so that's not a solution. I've tried flushing the DNS cache, reset TCP/IP and Winsock but it hasn't worked.

I'd appreciate help with this please. A little embarrassing that the company IT guy can't fix his own PC!
Windows 7SBS

Avatar of undefined
Last Comment
Morgan Machin

8/22/2022 - Mon
Morgan Machin

Did the wireless switch have DHCP enabled?
Roger Cooper

ASKER
Yes it did.
ASKER CERTIFIED SOLUTION
Morgan Machin

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
Bembi

It looks like the WLAN switch do not provide the information the clients needed. If the clients connects to the WLAN device, they should get the same information like they get in the wired connection. So check what the clients get, ie. subnet mask and standard gateway.
The information usually has to be provided by the WLAN device.

If DHCP is used, the WLAN device may not offer the right information. You can check this by IPConfig /all with a wired client and a wlan client.

Also make sure, the windows firewall or virus scanners involve in the communication .
Experts Exchange has (a) saved my job multiple times, (b) saved me hours, days, and even weeks of work, and often (c) makes me look like a superhero! This place is MAGIC!
Walt Forbes
Lee W, MVP

1. Disable DHCP on the Wireless Access Point.
2. Restart DHCP on the SBS server (SBS shuts DHCP down if it discovers another system handing out addresses.

You probably are getting bad DNS information and possibly route issues to the server depending on how the access point is configured.

Make the wireless router an ACCESS POINT ONLY - DO NOT plug anything into the WAN port and with DHCP disabled, things should return to normal with a workstation reboot (release/renew of IPs).
Morgan Machin

Hence, placing the wireless router into Bridge Mode so it's a WAP - passing through DHCP requests and acknowledgements.
Roger Cooper

ASKER
Hi, the DHCP was still enabled. It's now disabled. I'm restarting the server DHCP now.
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
Roger Cooper

ASKER
I've restarted the DHCP but it's coming up as unauthorized. When I try to authorize it the only option is to unauthorize? How do I get around this?
Morgan Machin

To turn on the Unauthorize option for the original DHCP server in Active Directory and then to authorize the DHCP server again, follow these steps:
1.Click Start, point to Programs, point to Administrative Tools, and then click DHCP.
2.Click the name of the original DHCP server.
3.On the Action menu, click Unauthorize.
4.When the Are you sure you want to do this? message appears, click Yes.
5.On the Action menu, click Authorize.
Roger Cooper

ASKER
Thanks Joshua. Actually from your first question I thought woops, I know what I've done.
This is the best money I have ever spent. I cannot not tell you how many times these folks have saved my bacon. I learn so much from the contributors.
rwheeler23
Morgan Machin

Yeah, roger that.