the name "<fqdn>" is already in use on this network. Type a name that is not in use. DCPROMO

Hey Guys,

I'm having a very strange issue setting up a domain.

I have an existing DNS server on an adhoc network.  It currently has 2 zones on it. I am setting up a domain controller on the network and would like to use one of the zones as the domain. I have the dynamic updates enabled on the zone that i'm trying to setup AD.

I keep getting the error of:

the name "<fqdn>" is already in use on this network. Type a name that is not in use.

What is strange is I then tried to create the domain with different extensions. I have tried .local, .corp, .lan, .net, .org even .asdf and i'm getting the same error every time.

I know for a FACT none of those are in use on the network.

I have even tried to uninstall the AD binaries and install just a DNS server with the name on it and point it to itself for DNS and then reinstall the binaries. No luck.

Any help would be greatly appreciated.
LVL 4
every1isevil2Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Mike KlineCommented:
Have you tried a different NetBIOS name...not just changing the suffix?

thanks

Mike

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
every1isevil2Author Commented:
yes. I have tried domain123456789.local and it still states that it is in use on the network. My apologies. I should have added that to the question.
every1isevil2Author Commented:
I actually think you are on to something. The netbios name is actually really long. Netbios only uses the first 16  characters of the domain name.... The domain name that i'm testing is 18 characters and I just added to that.  Let me see if i can shorten it out a bit.
every1isevil2Author Commented:
That was the problem. I had to change the domain completely due to the netbios name i was trying to use on the network was really long. I chose a much shorter domain name and it worked just fine.
Mike KlineCommented:
Glad to help and you learned a lot here so outstanding work!

Thanks

Mike
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Active Directory

From novice to tech pro — start learning today.