Mailbox unavailable Server response was: 5.7.1 Unable to relay

I have a scheduler application that sends out success/failure emails. the emails deliver with no issue to internal people, it is when it needs to send out that the intermittent "unable to relay" error happens. I have been informed to add the IP address of the scheduling server to the receive connectors and possibly add extra permission to the authenticated users group. I dont want to open the server up to spam. The outlook client email deliver with no issues to either local or outside the domain. so I am able to relay through that approach. Has anyone had a similar issue. what was the fix adding the IP address tothe connectors or adding permission to an ADS group or both.
SCFHPAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

RantCanSr. Systems AdministratorCommented:
If you create specific receive connectors for the IPs you need to, and set the permissions on those connectors to "Anonymous". You should be good.  You won't open up your mail server to spam if you restrict the receiver to one internal IP.
0
SCFHPAuthor Commented:
Can I add an extra ip address to an existing connector which is already set to only anonymous?
currently my "internet mail" connector has only has the exchnage server IP address. I thinking I would need to add any server IP address that I want to be able to send out to the world to that connector.

thank you for your input.
0
RantCanSr. Systems AdministratorCommented:
I would create a new receiver connecter (so far as I know there isn't a limit) named "scheduler" and put in the internal IP address for it, set the authentication to anonymous and test your mail flow from that host.
0
Introducing Cloud Class® training courses

Tech changes fast. You can learn faster. That’s why we’re bringing professional training courses to Experts Exchange. With a subscription, you can access all the Cloud Class® courses to expand your education, prep for certifications, and get top-notch instructions.

SCFHPAuthor Commented:
thank you for your responses.

I have another question. I opened a putty session on the exchange server and type these command in
Telnet onto the SMTP Server
Ex. telnet mailserver.com 25

Type in HELO <mailserver>
Ex. HELO test.mailserver.com

Type Mail From:<email address email From field> Ex. mail from:test@test.com

Type RCPT TO:<Email address to send email to> Ex. rcpt to:home@test.com
when I get to this point all internal email addresses work but if I put an exteranl email address in it gives me the relay error. is it possible that the receive connectors are preventing this or soemthing else. I can send email no problem from the outlook client to anyone outside the network no problem. If I make a new recieve connector for the scheduler will that make any difference since I am unable to relay from exchange directly?

thanks
0
RantCanSr. Systems AdministratorCommented:
What version of Exchange are you running?  Also, is your Exchange sending directly to the internet, or are you moving your mail through an MXlogic provider like SpamSoap or McAfee? To that, have you checked if your mail domain is blacklisted?
0
SCFHPAuthor Commented:
I am running exchange 2007 sp1. I have checked and my domain is not blacklisted. yes email is going directly to the internet. I added my workstation IP address to the default connector which has most of the auth settings checked and in the permission group the only one not checked is "partners". I not sure what else I need to do to be able to relay. I opened a putty session on the exchange server and same issue unable to relay.

I can try making a new connector as you suggested but not sure if that will make a difference since the internet mail connecotr I have is setup similarly.
0
RantCanSr. Systems AdministratorCommented:
Have you restarted the Transport service since all these changes have been made? 2007 is persnickety this way...
0
SCFHPAuthor Commented:
No I have. I am doing a reboot on exchnage this weekend.
I also noticed that my internet receive connector does not have this right

Add-AdPermission -Identity "Default Hub1" -User "NT AUTHORITY\ANONYMOUS LOGON"
-ExtendedRights ms-Exch-SMTP-Submit,ms-Exch-SMTP-Accept-Any-Recipient,ms-Exch-Bypass-Anti-Spam


would applying this permission allow my exchnage server to be used to relay spam? my exchnage server is behind a spam filter and ids/ips rules.
0
RantCanSr. Systems AdministratorCommented:
Anti-spam is a feature of Exchange Enterprise, so bypassing should have no effect on Standard.  If you have your exchange behind a spam filter you should be good.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Email Software

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.