SSRS wont run because of view

I have a SQL report that is built with Visual Studio 2010, the report was built for in house reporting and looks to several views in our dbase. It runs fine when I do so from visual studio, but I now would like to automate this and pulled the report into SSRS and tried to subscribe it out. The report will not run in SSRS because it doesn't recognize the views, only the actual tables. It's a fairly lengthy and complex report written by someone much smarter than I, so fooling around with the report code is a last resort. I tried adding a dataset and made a simple SQL statement SELECT * FROM AA_SalesGRP and it sees the fields ok, but the actual report still chokes when run on SSRS.

the error I get when trying to run the report from SSRS

An error has occurred during report processing. (rsProcessingAborted)
Query execution failed for dataset 'AA_SalesGRP'. (rsErrorExecutingCommand)
Invalid object name 'AA_SalesGRP'.
Jeremy KirkbrideAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Russell FoxDatabase DeveloperCommented:
It could be a security issue where the login running the report doesn't have access to the views: you'll need to find out what account is being used to run the query (look at the data source), and then make sure that account has access to the view objects in the database. In Management Studio, open that database, click Security, then Users. Either the data source login should be in there or the data source login should have Admin-level rights (not recommended). If that login is in there, right-click it and select Properties to see what kind of privileges it has.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Jeremy KirkbrideAuthor Commented:
It was a permission issue.  I found the error as I drilled down through the access/mapping/role permissions.  Thank you for your help, it was staring me right in the face.
0
Russell FoxDatabase DeveloperCommented:
We've all been there...
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SQL Server 2008

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.