[Webinar] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

Hw to influence BGP over EIGRP

Posted on 2014-07-11
7
Medium Priority
?
455 Views
Last Modified: 2014-07-19
I have Routers R1,R2,R3. R1 and R2 are IBGP peers and R3 is EBGP peers with R2 and R1

from R1 I am advertising network 1.1.1.1 and 10.10.10.10  through EIGRP and BGP.
However on R2 I do not see those networks in BGP Routing Table. The same Networks I can see them in R3 BGP Routing table.
I tried to redistribute from R1 the EIGRP with higher metric than BGP, but still cannot see the Networks specified above in the BGP Routing table of R2

R1
router eigrp 1
 network 1.1.1.1 0.0.0.0
 network 10.10.10.10 0.0.0.0
 network 172.16.12.0 0.0.0.255
!
router bgp 605
 no synchronization
 bgp log-neighbor-changes
 network 1.1.1.1 mask 255.255.255.255
 network 10.10.10.10 mask 255.255.255.255
 network 172.16.12.0 mask 255.255.255.0
 redistribute eigrp 1 metric 100000
 neighbor 2.2.2.2 remote-as 605
 no auto-summary

Open in new window


R2
router eigrp 1
 network 2.2.2.2 0.0.0.0
 network 172.16.12.0 0.0.0.255
 network 192.16.23.0
 network 192.16.203.0
!
router bgp 605
 no synchronization
 bgp log-neighbor-changes
 network 2.2.2.2 mask 255.255.255.255
 network 3.3.3.3 mask 255.255.255.255
 network 172.16.12.0 mask 255.255.255.0
 network 192.16.23.0
 network 192.16.203.0
 neighbor 1.1.1.1 remote-as 605
 neighbor 1.1.1.1 update-source Loopback0
 neighbor 1.1.1.1 next-hop-self
 neighbor 3.3.3.3 remote-as 777
 neighbor 3.3.3.3 ebgp-multihop 2
 neighbor 3.3.3.3 update-source Loopback0
 neighbor 3.3.3.3 next-hop-self
 no auto-summary

Open in new window


R3
router eigrp 1
 network 3.3.3.3 0.0.0.0
 network 192.16.23.0
 network 192.16.203.0
!
router bgp 777
 no synchronization
 bgp log-neighbor-changes
 network 20.20.20.0 mask 255.255.255.0
 network 30.30.30.0 mask 255.255.255.0
 network 192.16.23.0
 network 192.16.203.0
 neighbor 2.2.2.2 remote-as 605
 neighbor 2.2.2.2 ebgp-multihop 2
 neighbor 2.2.2.2 update-source Loopback0
 no auto-summary

Open in new window



R1#sh ip route bgp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, + - replicated route

Gateway of last resort is not set

      20.0.0.0/24 is subnetted, 1 subnets
B        20.20.20.0 [200/0] via 2.2.2.2, 00:00:45
      30.0.0.0/24 is subnetted, 1 subnets
B        30.30.30.0 [200/0] via 2.2.2.2, 00:00:45

Open in new window


R2#  sh ip route bgp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, + - replicated route

Gateway of last resort is not set

      20.0.0.0/24 is subnetted, 1 subnets
B        20.20.20.0 [20/0] via 3.3.3.3, 00:01:20
      30.0.0.0/24 is subnetted, 1 subnets
B        30.30.30.0 [20/0] via 3.3.3.3, 00:01:20

Open in new window


 
R3# sh ip route bgp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, + - replicated route

Gateway of last resort is not set

      1.0.0.0/32 is subnetted, 1 subnets
B        1.1.1.1 [20/0] via 2.2.2.2, 00:01:54
      2.0.0.0/32 is subnetted, 1 subnets
B        2.2.2.2 [20/0] via 2.2.2.2, 00:01:54
      10.0.0.0/24 is subnetted, 1 subnets
B        10.10.10.0 [20/0] via 2.2.2.2, 00:01:54
      172.16.0.0/24 is subnetted, 1 subnets
B        172.16.12.0 [20/0] via 2.2.2.2, 00:01:54
R3#

Open in new window

0
Comment
Question by:jskfan
  • 4
  • 3
7 Comments
 
LVL 28

Expert Comment

by:mikebernhardt
ID: 40191598
Do you see those routes in the EIGRP routing table on R2? Do you see them on R2 if you type "show ip bgp"

Remember that IBGP has a AD of 200 while EIGRP is 90. So you will not see IBGP routes if an IGP route is available. But they should show up in show ip bgp
0
 

Author Comment

by:jskfan
ID: 40192032
<<<<Do you see those routes in the EIGRP routing table on R2? Do you see them on R2 if you type "show ip bhp">>>>

I do not have the LAB open now but  I am sure the routes show up in EIGRP table on R2.
but they do not show up , when I type show IP bhp on R2. I posted the output above .

the stunning thing is the same routes show up in R3 BGP table when I type show ip BGP  as I posted the output above for R3

As of Administrative Distance, I know that IBGP has 200 and EIGRP is 90, this is why I include the command below on R1:
 redistribute eigrp 1 metric 100000

Regardless of that as I said the routes 1.1.1.1 and 10.10.10.0 still do not show up in BGP table of R2 but show up in BGP table of R3, even though R3 is connected to R2 and not to R1.
0
 

Author Comment

by:jskfan
ID: 40192034
the topology :
bgpp
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 28

Assisted Solution

by:mikebernhardt
mikebernhardt earned 2000 total points
ID: 40195238
"sho ip bgp" is completely different from "show ip route bgp." It doesn't matter if you redistributed the routes into BGP. "Show ip route bgp" shows you the bgp routes that are in the routing table, and IBGP routes will NEVER show up in the routing table if there is an equivalent EIGRP route there.
0
 

Author Comment

by:jskfan
ID: 40197676
redistribute eigrp 1 metric 100000

I guess the command above will still keep the Administrative Distance of EIGRP to 90
metric will just change the cost, I believe
0
 
LVL 28

Accepted Solution

by:
mikebernhardt earned 2000 total points
ID: 40198298
The above just puts the EIGRP routes into BGP. So "show ip route bgp" will not show you bgp routes because all that's doing is giving you the subset of routes in the routing table which are bgp, and the router will always prefer EIGRP if it has both options available.

IBGP is usually used to share EBGP routes between 2 routers in the same AS, not to route traffic between them. The router will not advertise BGP routes anyway unless there is an underlying IGP route so you will nearly always have both. If you see the EBGP routes on both routers, it's working as it should.
0
 

Author Closing Comment

by:jskfan
ID: 40206113
I will go back to the LAB later and try your approach, then post a question if I need to.
Thank you !!
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

We've been using the Cisco/Linksys RV042 for years as: - an internet Gateway - a site-to-site VPN device - a leased line site-to-site subnet-to-subnet interface (And, here I'm assuming that any RV0xx behaves the same way as an RV042.  So that's …
Getting hacked is no longer a matter or "if you get hacked" — the 2016 cyber threat landscape is now titled "when you get hacked." When it happens — will you be proactive, or reactive?
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

864 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question