Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1575
  • Last Modified:

Cisco SG500 Stack and Vlan

Hi

I have a strange scenario I need some help with.
We have purchased 6 L3 SG500 52 port switches (one arrived faulty and has been rma'd) now I’m wondering if I don’t have another faulty switch.

I followed the following steps in this order to configure them as a stack and Vlans,

I have setup 3 sg500 52 with a stack (ring)
10\5gig Cable from sw1 S3 to sw3 S4
10\5gig Cable from sw1 S4 to sw2 S3
10\5gig Cable from sw2 S4 to sw3 S3
I forced sw1 as the master.

1. Enable L3 routing.
2. Changed default VLAN to 10.
3. Created 3 additional VLANS 11, 12, 13.
4. Assigned respective IP to each VLAN.
5. Set the default route on the switch to point to the router.
6. Placed return paths from the firewall to the switch for vlan networks so respective vlans have internet access.

Then I started assigning ports to their respective VLAN, ie,
sw1 port 1-40 vlan 10 (untagged and other vlans exclude, this is set by default)
sw2 port 10-25 vlan 11 (untagged and other vlans exclude, this is set by default)
sw3 port 1-48 vlan 12 (untagged and other vlans exclude, this is set by default)

I enabled DHCP with the relevant ip adress and gateways to each vlan respectively.
ie, vlan 12
IP 192.168.12.0/24
GW 192.168.12.40 (Vlan IP address)
DNS 192.168.10.10 (Local DNS Server)

All machines on their respective vlan received the correct IP and there was communication between vlans for a period of time. After about an hour or 2 I could not access the switch stack unless I logged through the console (it did respond to Pings), machines lost access to internet and resources, so I reloaded the stack. Everything started working again for another hour or so and it went down again.

I reset the whole lot and started from scratch went through the process of setting the stack up again and vlan config, this time I only added 15 machines to one vlan 12 and again I lost access to the stack until I reloaded it from the console.

At this point I reset the whole lot and left it running in standard switch mode.

Im wondering if there is a step I have left out or if I have another faulty switch.

Can anyone shed some light on this?
0
lcete
Asked:
lcete
  • 3
1 Solution
 
Craig BeckCommented:
That sounds like a firmware issue to me.

Are all switches running the same version of code before you stack them?
0
 
lceteAuthor Commented:
hi there

i updated to latest firmware and boot of all switches before starting to work on them.
0
 
lceteAuthor Commented:
The problem was down to a faulty switch....
0
 
lceteAuthor Commented:
the problem was hardware
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now